Update wrt-plugins-common_0.3.53
[framework/web/wrt-plugins-common.git] / src / Commons / CMakeLists.txt
old mode 100755 (executable)
new mode 100644 (file)
index 33b126a..a195bc9
@@ -29,14 +29,16 @@ endmacro()
 
 include_config_file(WrtAccess)
 
-pkg_search_module(wrt-plugin-api REQUIRED wrt-plugin-api>=0.7.0)
+pkg_search_module(plugin-types REQUIRED wrt-plugins-types)
 pkg_search_module(ace-client REQUIRED ace-client)
 pkg_search_module(dpl-event REQUIRED dpl-event-efl)
+pkg_search_module(icu REQUIRED icu-i18n)
 
 set(WRT_COMMONS_DEPENDECIES_INCLUDES
-    ${INCLUDE_JS_INDEPENDENT}
     ${wrt-plugin-api_INCLUDE_DIRS}
     ${ace-client_INCLUDE_DIRS}
+    ${plugin-types_INCLUDE_DIRS}
+    ${icu_INCLUDE_DIRS}
     )
 
 include_directories(${WRT_COMMONS_DEPENDECIES_INCLUDES})
@@ -52,6 +54,9 @@ set(SRCS
   ${CMAKE_CURRENT_SOURCE_DIR}/StringBuilder.cpp
   ${CMAKE_CURRENT_SOURCE_DIR}/StringUtils.cpp
   ${CMAKE_CURRENT_SOURCE_DIR}/ThreadPool.cpp
+  ${CMAKE_CURRENT_SOURCE_DIR}/JSObjectDeclaration.cpp
+  ${CMAKE_CURRENT_SOURCE_DIR}/JSObject.cpp
+  ${CMAKE_CURRENT_SOURCE_DIR}/TimeUtils.cpp
   #PARENT_SCOPE
 )
 
@@ -60,7 +65,9 @@ target_link_libraries(${TARGET_NAME}
   ${LIBS_COMMONS}
   ${ace-client_LIBRARIES}
   ${dpl-event_LIBRARIES}
+  ${icu_LIBRARIES}
 )
+
 set_target_properties(${TARGET_NAME} PROPERTIES 
  SOVERSION ${CMAKE_PROJECT_API_VERSION}
  VERSION ${CMAKE_PROJECT_VERSION}
@@ -92,4 +99,7 @@ install_header_file(ThreadPool.h)
 install_header_file(TypesDeclaration.h)
 install_header_file(TypeTraits.h)
 install_header_file(plugin_initializer_def.h)
+install_header_file(JSObjectDeclaration.h)
+install_header_file(JSObject.h)
+install_header_file(TimeUtils.h)
 install_wrtaccess_header_file(WrtAccess/WrtAccess.h)