Update wrt-installer_0.0.54
[framework/web/wrt-installer.git] / src / CMakeLists.txt
index b25090b..559fa55 100755 (executable)
@@ -52,7 +52,6 @@ SET(INSTALLER_SOURCES
     ${INSTALLER_CONFIG_PARSER}/ignoring_parser.cpp
     ${INSTALLER_CONFIG_PARSER}/deny_all_parser.cpp
     ${INSTALLER_CONFIG_PARSER}/libiriwrapper.cpp
-    ${INSTALLER_CONFIG_PARSER}/WidgetConfigurationManager.cpp
     ${INSTALLER_JOBS}/job.cpp
     ${INSTALLER_JOBS}/plugin_install/job_plugin_install.cpp
     ${INSTALLER_JOBS}/plugin_install/plugin_install_task.cpp
@@ -64,6 +63,7 @@ SET(INSTALLER_SOURCES
     ${INSTALLER_JOBS}/widget_install/task_unzip.cpp
     ${INSTALLER_JOBS}/widget_install/task_widget_config.cpp
     ${INSTALLER_JOBS}/widget_install/task_db_update.cpp
+    ${INSTALLER_JOBS}/widget_install/task_file_manipulation.cpp
     ${INSTALLER_JOBS}/widget_install/task_smack.cpp
     ${INSTALLER_JOBS}/widget_install/task_ace_check.cpp
     ${INSTALLER_JOBS}/widget_install/task_manifest_file.cpp
@@ -90,6 +90,7 @@ SET(INSTALLER_SOURCES
     ${INSTALLER_SRC_DIR}/misc/wac_widget_id.cpp
     ${INSTALLER_SRC_DIR}/misc/feature_logic.cpp
     ${INSTALLER_SRC_DIR}/misc/libxml_utils.cpp
+    ${INSTALLER_SRC_DIR}/misc/widget_location.cpp
     ${INSTALLER_SRC_DIR}/pkg-manager/pkgmgr_signal.cpp
     )