tizen 2.4 release
[framework/web/wrt-commons.git] / examples / dbus / client-example / CMakeLists.txt
index 1f9241f..48add08 100644 (file)
@@ -1,24 +1,24 @@
-cmake_minimum_required(VERSION 2.6)
-project(client-example)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+PROJECT(client-example)
 
-include(FindPkgConfig)
+INCLUDE(FindPkgConfig)
 
-pkg_check_modules(DEPS
+PKG_CHECK_MODULES(DEPS
                   dbus-1
                   dpl-efl
                   dpl-dbus-efl
                   REQUIRED)
 
-set(TARGET_NAME "client-example")
+SET(TARGET_NAME "client-example")
 
-set(SRCS
+SET(SRCS
     client-example.cpp)
 
-include_directories(${DEPS_INCLUDE_DIRS})
+INCLUDE_DIRECTORIES(${DEPS_INCLUDE_DIRS})
 
-add_definitions("-std=c++0x")
-add_definitions("-DDPL_LOGS_ENABLED")
+ADD_DEFINITIONS("-std=c++0x")
+ADD_DEFINITIONS("-DDPL_LOGS_ENABLED")
 
-add_executable(${TARGET_NAME} ${SRCS})
-target_link_libraries(${TARGET_NAME} ${DEPS_LIBRARIES})
+ADD_EXECUTABLE(${TARGET_NAME} ${SRCS})
+TARGET_LINK_LIBRARIES(${TARGET_NAME} ${DEPS_LIBRARIES})