upload tizen2.0 source
[framework/uifw/xorg/util/x11-xkb-utils.git] / xkbprint / configure.ac
index 51ed18d..811ab80 100644 (file)
@@ -21,24 +21,24 @@ dnl  PERFORMANCE OF THIS SOFTWARE.
 dnl
 dnl Process this file with autoconf to create configure.
 
-AC_PREREQ([2.57])
-AC_INIT(xkbprint, [1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xkbprint)
-AM_INIT_AUTOMAKE([dist-bzip2])
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([xkbprint], [1.0.3],
+        [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xkbprint])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
 AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
 
-# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
 m4_ifndef([XORG_MACROS_VERSION],
-         [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
+          [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
 XORG_DEFAULT_OPTIONS
 
-AC_PROG_CC
-AC_PROG_INSTALL
-
 # Checks for pkg-config packages
 PKG_CHECK_MODULES(XKBPRINT, xkbfile x11)
-AC_SUBST(XKBPRINT_CFLAGS)
-AC_SUBST(XKBPRINT_LIBS)
 
 AC_OUTPUT([Makefile])