systemd: Add unit to export dlog debug variables globally
[framework/system/dlog.git] / packaging / dlog.spec
old mode 100644 (file)
new mode 100755 (executable)
index 3cf01ca..5b5d4db
@@ -1,16 +1,14 @@
-#sbs-git:slp/pkgs/d/dlog dlog 0.4.0 f2a67c71d044de4757f7eef9759c7f99d527462f
 Name:       dlog
 Summary:    Logging service
-Version:    0.4.0
-Release:    5.1
-Group:      TO_BE/FILLED_IN
-License:    TO BE FILLED IN
+Version:    0.4.1
+Release:    0.0
+Group:      System/Libraries
+License:    Apache License
 Source0:    %{name}-%{version}.tar.gz
-Source1:    packaging/99-android-logger.rules
 Source101:  packaging/dlog-main.service
 Source102:  packaging/dlog-radio.service
-Source103:  packaging/dlog-system.service
-
+Source103:  packaging/tizen-debug-level.service
+BuildRequires: pkgconfig(systemd)
 Requires(post): /sbin/ldconfig
 Requires(post): /usr/bin/systemctl
 Requires(post): /usr/bin/vconftool
@@ -53,7 +51,6 @@ utilities for print log data
 
 
 %build
-
 %autogen --disable-static
 %configure --disable-static
 make %{?jobs:-j%jobs}
@@ -61,6 +58,12 @@ make %{?jobs:-j%jobs}
 %install
 rm -rf %{buildroot}
 %make_install
+mkdir -p %{buildroot}/opt/etc/
+cp %{_builddir}/%{name}-%{version}/.dloglevel %{buildroot}/opt/etc/.dloglevel
+mkdir -p %{buildroot}/etc/profile.d/
+cp %{_builddir}/%{name}-%{version}/tizen_platform_env.sh %{buildroot}/etc/profile.d/tizen_platform_env.sh
+mkdir -p %{buildroot}/usr/bin/
+cp %{_builddir}/%{name}-%{version}/dlogctrl %{buildroot}/usr/bin/dlogctrl
 
 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc3.d
 mkdir -p %{buildroot}/%{_sysconfdir}/rc.d/rc5.d
@@ -69,66 +72,65 @@ rm -f %{buildroot}/%{_sysconfdir}/etc/rc.d/rc5.d/S05dlog
 ln -s ../init.d/dlog.sh %{buildroot}/%{_sysconfdir}/rc.d/rc3.d/S05dlog
 ln -s ../init.d/dlog.sh %{buildroot}/%{_sysconfdir}/rc.d/rc5.d/S05dlog
 
+mkdir -p %{buildroot}%{_libdir}/systemd/system/basic.target.wants
 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
-mkdir -p %{buildroot}%{_libdir}/udev/rules.d
 
 install -m 0644 %SOURCE101 %{buildroot}%{_libdir}/systemd/system/
 install -m 0644 %SOURCE102 %{buildroot}%{_libdir}/systemd/system/
 install -m 0644 %SOURCE103 %{buildroot}%{_libdir}/systemd/system/
-install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/udev/rules.d/
 
 ln -s ../dlog-main.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/dlog-main.service
 ln -s ../dlog-radio.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/dlog-radio.service
-ln -s ../dlog-system.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/dlog-system.service
+ln -s ../tizen-debug-level.service %{buildroot}%{_libdir}/systemd/system/basic.target.wants/tizen-debug-level.service
 
-mkdir -p %{buildroot}/opt/etc/
-cp %{_builddir}/%{name}-%{version}/.debuglevel %{buildroot}/opt/etc/.debuglevel
+mkdir -p %{buildroot}/usr/share/license
+cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 
 %preun -n dlogutil
 if [ $1 == 0 ]; then
     systemctl stop dlog-main.service
     systemctl stop dlog-radio.service
-    systemctl stop dlog-system.service
 fi
 
 %post -n dlogutil
+mkdir -p /opt/etc/dlog
+chown 0:5000 /opt/etc/dlog
+chmod 775 /opt/etc/dlog
+chmod 755 /usr/bin/dlogctrl
 systemctl daemon-reload
 if [ $1 == 1 ]; then
     systemctl restart dlog-main.service
     systemctl restart dlog-radio.service
-    systemctl restart dlog-system.service
 fi
 
 %postun -n dlogutil
 systemctl daemon-reload
 
 %post -n libdlog
-chmod +x /opt/etc/.debuglevel
-rm -f /etc/profile.d/dlevel.sh
-ln -s /opt/etc/.debuglevel /etc/profile.d/dlevel.sh
 /sbin/ldconfig
-
 %postun -n libdlog
 /sbin/ldconfig
 
 %files  -n dlogutil
 %manifest dlogutil.manifest
 %{_bindir}/dlogutil
+%{_bindir}/dlogctrl
 %{_sysconfdir}/rc.d/init.d/dlog.sh
 %{_sysconfdir}/rc.d/rc3.d/S05dlog
 %{_sysconfdir}/rc.d/rc5.d/S05dlog
+%{_libdir}/systemd/system/tizen-debug-level.service
 %{_libdir}/systemd/system/dlog-main.service
 %{_libdir}/systemd/system/dlog-radio.service
-%{_libdir}/systemd/system/dlog-system.service
+%{_libdir}/systemd/system/basic.target.wants/tizen-debug-level.service
 %{_libdir}/systemd/system/multi-user.target.wants/dlog-main.service
 %{_libdir}/systemd/system/multi-user.target.wants/dlog-radio.service
-%{_libdir}/systemd/system/multi-user.target.wants/dlog-system.service
-%{_libdir}/udev/rules.d/99-android-logger.rules
 
 %files  -n libdlog
+/usr/share/license/%{name}
 %doc LICENSE
-/opt/etc/.debuglevel
+/opt/etc/.dloglevel
+/etc/profile.d/tizen_platform_env.sh
 %{_libdir}/libdlog.so.0
 %{_libdir}/libdlog.so.0.0.0