tizen 2.3 release
[framework/multimedia/gst-plugins-ext0.10.git] / submux / src / Makefile.am
similarity index 68%
rename from mobile/toggle/src/Makefile.am
rename to submux/src/Makefile.am
index 4d761d7..695e81c 100755 (executable)
@@ -1,30 +1,27 @@
-# plugindir is set in configure\r
-\r
-##############################################################################\r
-# change libgstplugin.la to something more suitable, e.g. libmysomething.la  #\r
-##############################################################################\r
-plugin_LTLIBRARIES = libgsttoggle.la\r
-\r
-##############################################################################\r
-# for the next set of variables, rename the prefix if you renamed the .la,   #\r
-#  e.g. libgstplugin_la_SOURCES => libmysomething_la_SOURCES                 #\r
-#       libgstplugin_la_CFLAGS  => libmysomething_la_CFLAGS                  #\r
-#       libgstplugin_la_LIBADD  => libmysomething_la_LIBADD                  #\r
-#       libgstplugin_la_LDFLAGS => libmysomething_la_LDFLAGS                 #\r
-##############################################################################\r
-\r
-# sources used to compile this plug-in\r
-libgsttoggle_la_SOURCES = gsttoggle.c\r
-                                 \r
-                                 \r
-\r
-# flags used to compile this plugin\r
-# add other _CFLAGS and _LIBS as needed\r
-libgsttoggle_la_CFLAGS = $(GST_CFLAGS) \r
-libgsttoggle_la_LIBADD = $(GST_LIBS)  $(GST_BASE_LIBS)  \r
-#libgsttoggle_la_LIBADD = $(GST_BASE_LIBS)  \r
-libgsttoggle_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)\r
-\r
-# headers we need but don't want installed\r
-noinst_HEADERS = gsttoggle.h\r
-\r
+# plugindir is set in configure
+
+##############################################################################
+# change libgstplugin.la to something more suitable, e.g. libmysomething.la  #
+##############################################################################
+plugin_LTLIBRARIES = libgstsubmux.la
+
+##############################################################################
+# for the next set of variables, rename the prefix if you renamed the .la,   #
+#  e.g. libgstplugin_la_SOURCES => libmysomething_la_SOURCES                 #
+#       libgstplugin_la_CFLAGS  => libmysomething_la_CFLAGS                  #
+#       libgstplugin_la_LIBADD  => libmysomething_la_LIBADD                  #
+#       libgstplugin_la_LDFLAGS => libmysomething_la_LDFLAGS                 #
+##############################################################################
+
+# sources used to compile this plug-in
+libgstsubmux_la_SOURCES = gstsubmux.c
+
+# flags used to compile this plugin
+# add other _CFLAGS and _LIBS as needed
+libgstsubmux_la_CFLAGS = $(GST_CFLAGS) $(DRM_CLIENT_CFLAGS) $(DRM_TRUSTED_CFLAGS) $(MMTA_CFLAGS) -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+libgstsubmux_la_LIBADD = $(GST_LIBS) $(DRM_CLIENT_LIBS)$(DRM_TRUSTED_LIBS) $(GST_BASE_LIBS) $(MMTA_LIBS)$(GST_APP_LIBS) -lgstapp-0.10 $(CRYPTO_LIBS)
+libgstsubmux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+# headers we need but don't want installed
+noinst_HEADERS = gstsubmux.h
+