tizen 2.3 release
[framework/multimedia/gst-plugins-ext0.10.git] / Makefile.am
similarity index 67%
rename from wearable/Makefile.am
rename to Makefile.am
index e8e3e20..e75ed8c 100755 (executable)
@@ -5,12 +5,12 @@ aclocaldir = $(datadir)/aclocal
 
 SUBDIRS = common
 
-if GST_EXT_USE_EXT_ENCODEBIN
-SUBDIRS += encodebin
+if GST_EXT_USE_EXT_PIFFDEMUX
+SUBDIRS += piffdemux
 endif
 
-if GST_EXT_USE_EXT_AVSYSTEM
-SUBDIRS += avsystem
+if GST_EXT_USE_EXT_ENCODEBIN
+SUBDIRS += encodebin
 endif
 
 if GST_EXT_USE_EXT_EVASIMAGESINK
@@ -25,6 +25,12 @@ if GST_EXT_USE_EXT_XVIMAGESRC
 SUBDIRS += xvimagesrc
 endif
 
+if GST_EXT_USE_EXT_DRMSRC
+SUBDIRS += drmsrc
+endif
+if GST_EXT_USE_EXT_SUBMUX
+SUBDIRS += submux
+endif
 if GST_EXT_USE_EXT_TOGGLE
 SUBDIRS += toggle
 endif
@@ -41,18 +47,26 @@ if GST_EXT_USE_EXT_AUDIOEQ
 SUBDIRS += audioeq
 endif
 
+if GST_EXT_USE_EXT_SSDEMUX
+SUBDIRS += ssdemux
+endif
+
 if GST_EXT_USE_EXT_DASHDEMUX
 SUBDIRS += dashdemux
 endif
 
+if GST_EXT_USE_EXT_HLSDEMUX2
+SUBDIRS += hlsdemux2
+endif
+
 DIST_SUBDIRS = common
 
-if GST_EXT_USE_EXT_ENCODEBIN
-DIST_SUBDIRS += encodebin
+if GST_EXT_USE_EXT_PIFFDEMUX
+DIST_SUBDIRS += piffdemux
 endif
 
-if GST_EXT_USE_EXT_AVSYSTEM
-DIST_SUBDIRS += avsystem
+if GST_EXT_USE_EXT_ENCODEBIN
+DIST_SUBDIRS += encodebin
 endif
 
 if GST_EXT_USE_EXT_EVASIMAGESINK
@@ -63,14 +77,28 @@ if GST_EXT_USE_EXT_XVIMAGESRC
 DIST_SUBDIRS += xvimagesrc
 endif
 
+if GST_EXT_USE_EXT_DRMSRC
+DIST_SUBDIRS += drmsrc
+endif
+if GST_EXT_USE_EXT_SUBMUX
+DIST_SUBDIRS += submux
+endif
 if GST_EXT_USE_EXT_TOGGLE
 DIST_SUBDIRS += toggle
 endif
 
+if GST_EXT_USE_EXT_SSDEMUX
+DIST_SUBDIRS += ssdemux
+endif
+
 if GST_EXT_USE_EXT_DASHDEMUX
 DIST_SUBDIRS += dashdemux
 endif
 
+if GST_EXT_USE_EXT_HLSDEMUX2
+DIST_SUBDIRS += hlsdemux2
+endif
+
 EXTRA_DIST = \
        gstreamer.spec gstreamer.spec.in \
        configure.ac autogen.sh depcomp \