Release Tizen2.0 beta
[framework/location/gps-manager.git] / packaging / gps-manager.spec
index 21b4df0..1b862a1 100644 (file)
@@ -1,11 +1,10 @@
 Name:       gps-manager
-Summary:    GPS Manager for Tizen 
-Version:    0.1.6
+Summary:    GPS Manager for Tizen
+Version:    0.2.1
 Release:    1
 Group:      TO_BE/FILLED_IN
 License:    TO_BE/FILLED_IN
 Source0:    %{name}-%{version}.tar.gz
-BuildRequires:  cmake
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(dbus-glib-1)
 BuildRequires:  pkgconfig(geoclue)
@@ -23,12 +22,12 @@ BuildRequires:  pkgconfig(location)
 GPS Manager for Tizen
 
 %package -n location-gps-manager
-Summary:    GPS Manager for Tizen 
+Summary:    GPS Manager for Tizen
 Group:      Development/Libraries
 Requires:   %{name} = %{version}-%{release}
 
 %description -n location-gps-manager
-libslp-location module for gps-manager
+GPS Manager for Tizen
 
 
 %package -n gps-manager-plugin-devel
@@ -41,7 +40,7 @@ GPS Manager for Tizen (development files)
 
 
 %prep
-%setup -q 
+%setup -q
 
 %ifarch %{arm}
 %define GPS_ENABLER --enable-gps
@@ -52,7 +51,7 @@ GPS Manager for Tizen (development files)
 %endif
 
 ./autogen.sh
-CFLAGS="$CFLAGS" CXXFLAGS="$CXXFLAGS" LDFLAGS="$LDFLAGS" ./configure --prefix=%{_prefix} %{GPS_ENABLER}
+./configure --prefix=%{_prefix} %{GPS_ENABLER}
 
 
 %build
@@ -69,8 +68,9 @@ rm -rf %{buildroot}
 
 %post
 #GPS Indicator value
-vconftool set -t int memory/gps/state 0 -i
-vconftool set -t int memory/wps/state 0 -i
+vconftool set -t int memory/location/position/state 0 -i
+vconftool set -t int memory/location/gps/state 0 -i
+vconftool set -t int memory/location/wps/state 0 -i
 
 #GPS_SETTING
 vconftool set -t int db/location/gps/Operation "1" -f
@@ -78,9 +78,9 @@ vconftool set -t int db/location/gps/Starting "0" -f
 vconftool set -t int db/location/gps/Session "1" -f
 
 #SUPL_SETTING
-vconftool set -t string db/location/supl/Server "your.supl-server.com" -f
+vconftool set -t string db/location/supl/Server "bcmls2.glpals.com" -f
 vconftool set -t int db/location/supl/Port "7275" -f
-vconftool set -t int db/location/supl/SslEnabled "1" -f
+vconftool set -t int db/location/supl/SslEnabled "0" -f
 
 #NMEA_SETTING
 vconftool set -t int db/location/nmea/LoggingEnabled "0" -f
@@ -98,6 +98,11 @@ vconftool set -t double db/location/replay/ManualLatitude "0.0" -f
 vconftool set -t double db/location/replay/ManualLongitude "0.0" -f
 vconftool set -t double db/location/replay/ManualAltitude "0.0" -f
 
+%post -n location-gps-manager
+%ifnarch %arm
+       cp -f /usr/lib/location/module/libgps.so /usr/lib/location/module/libwps0.so
+%endif
+
 %postun -p /sbin/ldconfig
 
 %files