upload tizen1.0 source
[framework/location/gps-manager.git] / debian / rules
index b84999d..e58d7f6 100755 (executable)
@@ -19,8 +19,10 @@ DEB_HOST_ARCH       ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 ifneq (,$(findstring armel,$(DEB_HOST_ARCH)))
        GPS_ENABLER ?= --enable-gps
+       ARCH ?= armel
 else
-       GPS_ENABLER ?= --disable-gps
+       GPS_ENABLER ?= --enable-gps
+       ARCH ?= x86
 endif
 
 #CFLAGS ?= -Wall -g
@@ -66,6 +68,7 @@ build-stamp:  configure-stamp
                cat $$f > $${f%.in}; \
                sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
                sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+               sed -i -e "s#@ARCH@#$(ARCH)#g" $${f%.in}; \
        done
 
        touch $@