Git init
[framework/api/sim.git] / packaging / capi-telephony-sim.spec
1 Name:       capi-telephony-sim
2 Summary:    Telephony SIM Framework
3 Version:    0.0.1
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO BE FILLED IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(tapi)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(capi-base-common)
14 Requires(post): /sbin/ldconfig  
15 Requires(postun): /sbin/ldconfig
16
17 %description
18
19
20 %package devel
21 Summary:  Telephony SIM Framework (Development)
22 Group:    TO_BE/FILLED_IN
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26
27
28
29 %prep
30 %setup -q
31
32
33 %build
34 cmake . -DCMAKE_INSTALL_PREFIX=/usr
35
36
37 make %{?jobs:-j%jobs}
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47
48 %files
49 %{_libdir}/libcapi-telephony-sim.so
50
51 %files devel
52 %{_includedir}/telephony/sim.h
53 %{_libdir}/pkgconfig/*.pc
54
55