update for beta universally
[framework/api/sim.git] / packaging / capi-telephony-sim.spec
1 Name:       capi-telephony-sim
2 Summary:    Telephony SIM Framework
3 Version:    0.1.0
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(dlog)
10 BuildRequires:  pkgconfig(tapi)
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(capi-base-common)
14 Requires(post): /sbin/ldconfig  
15 Requires(postun): /sbin/ldconfig
16
17 %description
18
19
20 %package devel
21 Summary:  Telephony SIM Framework (Development)
22 Group:    TO_BE/FILLED_IN
23 Requires: %{name} = %{version}-%{release}
24
25 %description devel
26
27
28
29 %prep
30 %setup -q
31
32
33 %build
34 FULLVER=%{version}
35 MAJORVER=`echo ${FULLVER} | cut -d '.' -f 1`
36 cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
37
38
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 %make_install
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49
50 %files
51 %{_libdir}/libcapi-telephony-sim.so*
52
53 %files devel
54 %{_includedir}/telephony/sim.h
55 %{_libdir}/pkgconfig/*.pc
56
57