upload tizen1.0 source
[framework/api/power.git] / packaging / capi-system-power.spec
index b2895c7..286c281 100644 (file)
@@ -1,16 +1,18 @@
+#sbs-git:slp/api/power capi-system-power 0.1.0 0432661af455f52366bdcd809dc72a00854c763c
 Name:       capi-system-power
-Summary:    A power library in Tizen Native API
-Version:    0.1.0
-Release:    1
+Summary:    A power library in Tizen C API
+Version: 0.1.0
+Release:    7
 Group:      TO_BE/FILLED_IN
-License:    Apache-2.0
+License:    TO BE FILLED IN
 Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(dlog)
-BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(pmapi)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(capi-base-common)
+BuildRequires:  pkgconfig(vconf)
+
 Requires(post): /sbin/ldconfig  
 Requires(postun): /sbin/ldconfig
 
@@ -18,7 +20,7 @@ Requires(postun): /sbin/ldconfig
 
 
 %package devel
-Summary:  A power library in Tizen Native API (Development)
+Summary:  A power library in Tizen C API (Development)
 Group:    TO_BE/FILLED_IN
 Requires: %{name} = %{version}-%{release}
 
@@ -31,7 +33,8 @@ Requires: %{name} = %{version}-%{release}
 
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=/usr
+MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
+cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER}
 
 
 make %{?jobs:-j%jobs}
@@ -46,10 +49,11 @@ rm -rf %{buildroot}
 
 
 %files
-%{_libdir}/libcapi-system-power.so
+%{_libdir}/libcapi-system-power.so.*
 
 %files devel
 %{_includedir}/system/power.h
 %{_libdir}/pkgconfig/*.pc
+%{_libdir}/libcapi-system-power.so