tizen 2.3.1 release
[external/curl.git] / docs / libcurl / Makefile.am
index 3f949d6..c47678b 100644 (file)
@@ -1,8 +1,29 @@
+#***************************************************************************
+#                                  _   _ ____  _
+#  Project                     ___| | | |  _ \| |
+#                             / __| | | | |_) | |
+#                            | (__| |_| |  _ <| |___
+#                             \___|\___/|_| \_\_____|
 #
+# Copyright (C) 1998 - 2014, Daniel Stenberg, <daniel@haxx.se>, et al.
 #
+# This software is licensed as described in the file COPYING, which
+# you should have received as part of this distribution. The terms
+# are also available at http://curl.haxx.se/docs/copyright.html.
+#
+# You may opt to use, copy, modify, merge, publish, distribute and/or sell
+# copies of the Software, and permit persons to whom the Software is
+# furnished to do so, under the terms of the COPYING file.
+#
+# This software is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY
+# KIND, either express or implied.
+#
+###########################################################################
 
 AUTOMAKE_OPTIONS = foreign no-dependencies
 
+SUBDIRS = opts
+
 man_MANS = curl_easy_cleanup.3 curl_easy_getinfo.3 curl_easy_init.3     \
  curl_easy_perform.3 curl_easy_setopt.3 curl_easy_duphandle.3           \
  curl_formadd.3 curl_formfree.3 curl_getdate.3 curl_getenv.3            \
@@ -19,7 +40,7 @@ man_MANS = curl_easy_cleanup.3 curl_easy_getinfo.3 curl_easy_init.3    \
  curl_easy_unescape.3 curl_multi_setopt.3 curl_multi_socket.3           \
  curl_multi_timeout.3 curl_formget.3 curl_multi_assign.3                \
  curl_easy_pause.3 curl_easy_recv.3 curl_easy_send.3                    \
- curl_multi_socket_action.3
+ curl_multi_socket_action.3 curl_multi_wait.3
 
 HTMLPAGES = curl_easy_cleanup.html curl_easy_getinfo.html              \
  curl_easy_init.html curl_easy_perform.html curl_easy_setopt.html      \
@@ -39,7 +60,7 @@ HTMLPAGES = curl_easy_cleanup.html curl_easy_getinfo.html             \
  curl_easy_unescape.html curl_multi_setopt.html curl_multi_socket.html \
  curl_multi_timeout.html curl_formget.html curl_multi_assign.html      \
  curl_easy_pause.html curl_easy_recv.html curl_easy_send.html          \
- curl_multi_socket_action.html
+ curl_multi_socket_action.html curl_multi_wait.html
 
 PDFPAGES = curl_easy_cleanup.pdf curl_easy_getinfo.pdf                  \
  curl_easy_init.pdf curl_easy_perform.pdf curl_easy_setopt.pdf          \
@@ -58,22 +79,27 @@ PDFPAGES = curl_easy_cleanup.pdf curl_easy_getinfo.pdf                       \
  curl_easy_escape.pdf curl_easy_unescape.pdf curl_multi_setopt.pdf      \
  curl_multi_socket.pdf curl_multi_timeout.pdf curl_formget.pdf          \
  curl_multi_assign.pdf curl_easy_pause.pdf curl_easy_recv.pdf           \
- curl_easy_send.pdf curl_multi_socket_action.pdf
+ curl_easy_send.pdf curl_multi_socket_action.pdf curl_multi_wait.pdf
+
+m4macrodir = $(datadir)/aclocal
+dist_m4macro_DATA = libcurl.m4
 
 CLEANFILES = $(HTMLPAGES) $(PDFPAGES)
 
-EXTRA_DIST = $(man_MANS) $(HTMLPAGES) index.html $(PDFPAGES) libcurl.m4 ABI \
-  symbols-in-versions
+EXTRA_DIST = $(man_MANS) $(HTMLPAGES) index.html $(PDFPAGES) ABI \
+  symbols-in-versions symbols.pl
 MAN2HTML= roffit --mandir=. < $< >$@
 
 SUFFIXES = .3 .html
 
 html: $(HTMLPAGES)
+       cd opts; make html
 
 .3.html:
        $(MAN2HTML)
 
 pdf: $(PDFPAGES)
+       cd opts; make pdf
 
 .3.pdf:
        @(foo=`echo $@ | sed -e 's/\.[0-9]$$//g'`; \