mlx90614: added new sensor (ir temperature), there is an issue with repeated start...
[contrib/upm.git] / examples / CMakeLists.txt
index b2d3096..e33f668 100644 (file)
@@ -27,6 +27,7 @@ add_executable (max5487-example max5487.cxx)
 add_executable (nrf8001-broadcast-example nrf8001_broadcast.cxx)
 add_executable (nrf8001-helloworld-example nrf8001_helloworld.cxx)
 add_executable (lpd8806-example lpd8806-example.cxx)
+add_executable (mlx90614-example mlx90614-example.cxx)
 
 include_directories (${PROJECT_SOURCE_DIR}/src/hmc5883l)
 include_directories (${PROJECT_SOURCE_DIR}/src/grove)
@@ -51,6 +52,7 @@ include_directories (${PROJECT_SOURCE_DIR}/src/max31723)
 include_directories (${PROJECT_SOURCE_DIR}/src/max5487)
 include_directories (${PROJECT_SOURCE_DIR}/src/nrf8001)
 include_directories (${PROJECT_SOURCE_DIR}/src/lpd8806)
+include_directories (${PROJECT_SOURCE_DIR}/src/mlx90614)
 
 target_link_libraries (compass hmc5883l ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (groveled grove ${CMAKE_THREAD_LIBS_INIT})
@@ -81,3 +83,4 @@ target_link_libraries (max5487-example max5487 ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (nrf8001-broadcast-example nrf8001 ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (nrf8001-helloworld-example nrf8001 ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (lpd8806-example lpd8806 ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries (mlx90614-example mlx90614 ${CMAKE_THREAD_LIBS_INIT})