tcs3414cs:: added new color sensor
[contrib/upm.git] / examples / CMakeLists.txt
index 97ac0a6..a002c81 100644 (file)
@@ -33,6 +33,7 @@ add_executable (mq2-example mq2-example.cxx)
 add_executable (mq3-example mq3-example.cxx)
 add_executable (mq5-example mq5-example.cxx)
 add_executable (mq9-example mq9-example.cxx)
+add_executable (tcs3414cs-example tcs3414cs-example.cxx)
 
 include_directories (${PROJECT_SOURCE_DIR}/src/hmc5883l)
 include_directories (${PROJECT_SOURCE_DIR}/src/grove)
@@ -60,6 +61,7 @@ include_directories (${PROJECT_SOURCE_DIR}/src/lpd8806)
 include_directories (${PROJECT_SOURCE_DIR}/src/mlx90614)
 include_directories (${PROJECT_SOURCE_DIR}/src/ecs1030)
 include_directories (${PROJECT_SOURCE_DIR}/src/gas)
+include_directories (${PROJECT_SOURCE_DIR}/src/tcs3414cs)
 
 target_link_libraries (compass hmc5883l ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (groveled grove ${CMAKE_THREAD_LIBS_INIT})
@@ -96,3 +98,4 @@ target_link_libraries (mq2-example gas ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (mq3-example gas ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (mq5-example gas ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (mq9-example gas ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries (tcs3414cs-example tcs3414cs ${CMAKE_THREAD_LIBS_INIT})