max31855: add sensor and documentation on creation of a UPM sensor
[contrib/upm.git] / examples / CMakeLists.txt
index 98d3be6..7dc24fd 100644 (file)
@@ -15,6 +15,7 @@ add_executable (oled-1327 oled-1327.cxx)
 add_executable (proximity max44000.cxx)
 add_executable (accelerometer mma7455.cxx)
 add_executable (lcd st7735.cxx)
+add_executable (max31855-example max31855.cxx)
 
 include_directories (${PROJECT_SOURCE_DIR}/src/hmc5883l)
 include_directories (${PROJECT_SOURCE_DIR}/src/grove)
@@ -28,6 +29,7 @@ include_directories (${PROJECT_SOURCE_DIR}/src/hcsr04)
 include_directories (${PROJECT_SOURCE_DIR}/src/max44000)
 include_directories (${PROJECT_SOURCE_DIR}/src/mma7455)
 include_directories (${PROJECT_SOURCE_DIR}/src/st7735)
+include_directories (${PROJECT_SOURCE_DIR}/src/max31855)
 
 target_link_libraries (compass hmc5883l ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (groveled grove ${CMAKE_THREAD_LIBS_INIT})
@@ -46,3 +48,4 @@ target_link_libraries (oled-1327 i2clcd ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (proximity max44000 ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (accelerometer mma7455 ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (lcd st7735 ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries (max31855-example max31855 ${CMAKE_THREAD_LIBS_INIT})