max31723 :: added new temperature sensor (HAVE ISSUES WITH SPI)
[contrib/upm.git] / examples / CMakeLists.txt
index 9fc6ffa..5d14ecd 100644 (file)
@@ -22,6 +22,7 @@ add_executable (pulsensor-example pulsensor.cxx)
 add_executable (mic-example mic-example.cxx)
 add_executable (mpu9150-example mpu9150-example.cxx)
 add_executable (maxds3231m-example maxds3231m.cxx)
+add_executable (max31723-example max31723.cxx)
 
 include_directories (${PROJECT_SOURCE_DIR}/src/hmc5883l)
 include_directories (${PROJECT_SOURCE_DIR}/src/grove)
@@ -42,6 +43,7 @@ include_directories (${PROJECT_SOURCE_DIR}/src/pulsensor)
 include_directories (${PROJECT_SOURCE_DIR}/src/mic)
 include_directories (${PROJECT_SOURCE_DIR}/src/mpu9150)
 include_directories (${PROJECT_SOURCE_DIR}/src/maxds3231m)
+include_directories (${PROJECT_SOURCE_DIR}/src/max31723)
 
 target_link_libraries (compass hmc5883l ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (groveled grove ${CMAKE_THREAD_LIBS_INIT})
@@ -67,3 +69,4 @@ target_link_libraries (pulsensor-example pulsensor ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (mic-example mic ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (mpu9150-example mpu9150 ${CMAKE_THREAD_LIBS_INIT})
 target_link_libraries (maxds3231m-example maxds3231m ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries (max31723-example max31723 ${CMAKE_THREAD_LIBS_INIT})