tizen_2.0_build
[apps/home/starter.git] / packaging / starter.spec
index e6909ea..ab4196b 100755 (executable)
@@ -1,9 +1,9 @@
 Name:       starter
 Summary:    starter
-Version:    0.4.0
+Version: 0.4.11
 Release:    1
-Group:      Apache
-License:    TO_BE/FILLED_IN
+Group:      TO_BE/FILLED_IN
+License:    Flora Software License
 Source0:    starter-%{version}.tar.gz
 Requires(post): /usr/bin/vconftool
 BuildRequires:  cmake
@@ -18,6 +18,7 @@ BuildRequires:  pkgconfig(ecore)
 BuildRequires:  pkgconfig(evas)
 BuildRequires:  pkgconfig(utilX)
 BuildRequires:  pkgconfig(appcore-efl)
+BuildRequires:  pkgconfig(capi-appfw-application)
 
 %description
 Description: Starter
@@ -37,19 +38,30 @@ rm -rf %{buildroot}
 
 
 %post
-vconftool set -t int "memory/startapps/sequence" 0 -i -u 5000 -g 5000
-vconftool set -t string db/lockscreen/pkgname "org.tizen.draglock" -u 5000 -g 5000  
+change_file_executable()
+{
+    chmod +x $@ 2>/dev/null
+    if [ $? -ne 0 ]; then
+        echo "Failed to change the perms of $@"
+    fi
+}
+
+vconftool set -t int "memory/starter/sequence" 0 -i -u 5000 -g 5000
+vconftool set -t string file/private/lockscreen/pkgname "org.tizen.draglock" -u 5000 -g 5000
 vconftool -i set -t int memory/idle_lock/state "0" -u 5000 -g 5000
 
 ln -sf /etc/init.d/rd4starter /etc/rc.d/rc4.d/S81starter
 ln -sf /etc/init.d/rd3starter /etc/rc.d/rc3.d/S43starter
 
+change_file_executable /etc/opt/init/starter.init.sh
+/etc/opt/init/starter.init.sh
+
 sync
 
 %files
 %defattr(-,root,root,-)
+/etc/opt/init/starter.init.sh
 %{_sysconfdir}/init.d/rd4starter
 %{_sysconfdir}/init.d/rd3starter
 %{_bindir}/starter
 %{_libdir}/liblock-daemon.so
-