fix for applying wayland (removing X)
[apps/home/settings.git] / setting-password / CMakeLists.txt
index 9e51af1..de607e2 100755 (executable)
@@ -5,7 +5,7 @@ INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/${SETTING_COMMON}/include)
 
 INCLUDE(FindPkgConfig)
 
-pkg_check_modules(pkgs_password REQUIRED evas ecore edje elementary utilX appcore-common
+pkg_check_modules(pkgs_password REQUIRED evas ecore edje elementary appcore-common
 appcore-efl deviced ecore-imf
 ui-gadget-1 capi-appfw-application tapi dlog
 security-server notification
@@ -15,7 +15,7 @@ FOREACH(flag ${pkgs_password_CFLAGS})
        SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} ${flag}")
 ENDFOREACH(flag)
 
-SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_CFLAGS} -fPIC -Werror-implicit-function-declaration")
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_CFLAGS} -fPIC")
 SET(CMAKE_C_FLAGS_DEBUG "-O0 -g")
 
 IF("${ARCH}" STREQUAL "arm")