2015-08-25 |
bmeurer | Correctify instanceof and make it optimizable. |
blob | commitdiff | raw |
2015-08-17 |
mstarzinger | Remove grab-bag includes of v8.h from architecture... |
blob | commitdiff | raw | diff to current |
2015-07-31 |
yangguo | Debugger: move implementation to a separate folder. |
blob | commitdiff | raw | diff to current |
2015-07-23 |
danno | Unify "runtime-style" IC functions with Runtime intrinsics |
blob | commitdiff | raw | diff to current |
2015-07-13 |
verwaest | Fix keyed element access wrt string wrappers |
blob | commitdiff | raw | diff to current |
2015-07-13 |
yangguo | Debugger: refactor reloc info. |
blob | commitdiff | raw | diff to current |
2015-07-13 |
mstarzinger | Remove unused byte from Map::instance_sizes field. |
blob | commitdiff | raw | diff to current |
2015-07-10 |
bmeurer | Remove more uses of the deprecated EnumSet template... |
blob | commitdiff | raw | diff to current |
2015-06-17 |
jkummerow | Clean up JSConstructStub |
blob | commitdiff | raw | diff to current |
2015-06-01 |
erikcorry | Cosmetic changes to tests to make it easier to concaten... |
blob | commitdiff | raw | diff to current |
2015-05-26 |
erikcorry | Move hash code from hidden string to a private symbol |
blob | commitdiff | raw | diff to current |
2015-05-12 |
mvstanton | New hydrogen instruction to reduce cost of growing... |
blob | commitdiff | raw | diff to current |
2015-05-05 |
danno | Revert of Collect type feedback on result of Math.... |
blob | commitdiff | raw | diff to current |
2015-05-05 |
danno | Collect type feedback on result of Math.[round|ceil... |
blob | commitdiff | raw | diff to current |
2015-04-21 |
svenpanne | Removed src/{isolate,property-details,utils}-inl.h |
blob | commitdiff | raw | diff to current |
2015-04-16 |
bmeurer | Revert of [x64] Use xorl to materialize smi zero. ... |
blob | commitdiff | raw | diff to current |
2015-04-15 |
bmeurer | [x64] Use xorl to materialize smi zero. |
blob | commitdiff | raw | diff to current |
2015-04-08 |
jing.bao | [x64] Introduce BMI instructions. |
blob | commitdiff | raw | diff to current |
2015-04-07 |
hpayer | Reland "Merge old data and pointer space." |
blob | commitdiff | raw | diff to current |
2015-03-27 |
yangguo | Serializer: move to a subfolder and clean up includes. |
blob | commitdiff | raw | diff to current |
2015-03-25 |
mstarzinger | Switch full-codegen from StackHandlers to handler table. |
blob | commitdiff | raw | diff to current |
2015-03-20 |
Benedikt Meurer | [turbofan] Turn Math.clz32 into an inlinable builtin. |
blob | commitdiff | raw | diff to current |
2015-03-19 |
hpayer | Revert "Merge old data and pointer space." |
blob | commitdiff | raw | diff to current |
2015-03-18 |
mstarzinger | Remove kind field from StackHandler. |
blob | commitdiff | raw | diff to current |
2015-03-18 |
hpayer | Merge old data and pointer space. |
blob | commitdiff | raw | diff to current |
2015-03-16 |
mstarzinger | Revert of Remove kind field from StackHandler. (patchse... |
blob | commitdiff | raw | diff to current |
2015-03-16 |
mstarzinger | Remove kind field from StackHandler. |
blob | commitdiff | raw | diff to current |
2015-03-10 |
mstarzinger | Remove frame pointer from StackHandler. |
blob | commitdiff | raw | diff to current |
2015-03-10 |
mstarzinger | Remove code object from StackHandler. |
blob | commitdiff | raw | diff to current |
2015-03-05 |
yangguo | Only reference constant root list entries in the snapshot. |
blob | commitdiff | raw | diff to current |
2015-03-05 |
bmeurer | [turbofan] Support for %_DoubleHi, %_DoubleLo and ... |
blob | commitdiff | raw | diff to current |
2015-03-03 |
mstarzinger | Move stack unwinding logic into the runtime. |
blob | commitdiff | raw | diff to current |
2015-02-27 |
bmeurer | [x64] Make r12 allocatable. |
blob | commitdiff | raw | diff to current |
2015-02-25 |
bmeurer | [x64] Improve materialization of certain double constan... |
blob | commitdiff | raw | diff to current |
2015-02-24 |
jkummerow | Move Maps' back pointers from "transitions" to "constru... |
blob | commitdiff | raw | diff to current |
2015-01-30 |
ulan | Load callback data from weak cell instead of embedding... |
blob | commitdiff | raw | diff to current |
2015-01-30 |
bmeurer | Reland "Initial switch to Chromium-style CHECK_* and... |
blob | commitdiff | raw | diff to current |
2015-01-30 |
Benedikt Meurer | Revert "Make GCC happy again." and "Initial switch... |
blob | commitdiff | raw | diff to current |
2015-01-30 |
bmeurer | Initial switch to Chromium-style CHECK_* and DCHECK_... |
blob | commitdiff | raw | diff to current |
2015-01-28 |
ulan | Extract LoadAccessor into a masm function. |
blob | commitdiff | raw | diff to current |
2015-01-21 |
Benedikt Meurer | Use signaling NaN for holes in fixed double arrays. |
blob | commitdiff | raw | diff to current |
2015-01-20 |
dcarney | move CallApiFunctionAndReturn to code-stubs-* |
blob | commitdiff | raw | diff to current |
2015-01-20 |
weiliang.lin | [x86] Avoid memory form of PUSH/CALL for ATOM. |
blob | commitdiff | raw | diff to current |
2015-01-20 |
dcarney | fix debug checks for api callbacks returning symbols |
blob | commitdiff | raw | diff to current |
2015-01-19 |
ishell | Massive renaming of PropertyType values and other impli... |
blob | commitdiff | raw | diff to current |
2015-01-16 |
dcarney | split api call stubs into accessor and function call... |
blob | commitdiff | raw | diff to current |
2015-01-08 |
jochen | Remove "extra checks" |
blob | commitdiff | raw | diff to current |
2014-12-22 |
ulan | Use weak cell in monomorphic KeyedStore IC. |
blob | commitdiff | raw | diff to current |
2014-12-03 |
ulan | Use weak cells to embed maps in store handler. |
blob | commitdiff | raw | diff to current |
2014-12-02 |
ulan | Reland parts of 'Use weak cells in map checks in polymo... |
blob | commitdiff | raw | diff to current |
2014-12-02 |
machenbach | Revert of Use weak cells in map checks in polymorphic... |
blob | commitdiff | raw | diff to current |
2014-12-01 |
ulan | Use weak cells in map checks in polymorphic ICs. |
blob | commitdiff | raw | diff to current |
2014-11-19 |
ishell | PropertyDetails cleanup: NORMAL property type merged... |
blob | commitdiff | raw | diff to current |
2014-10-17 |
jkummerow@chromium.org | Tick processor: Print C++ entry points |
blob | commitdiff | raw | diff to current |
2014-10-17 |
bmeurer@chromium.org | [x64] simply tweak materialization of float/double... |
blob | commitdiff | raw | diff to current |
2014-10-13 |
rmcilroy@chromium.org | Refactor FrameAndConstantPoolScope and ConstantPoolUnav... |
blob | commitdiff | raw | diff to current |
2014-09-23 |
svenpanne@chromium.org | Made the detailed reason for deopts mandatory on ia32... |
blob | commitdiff | raw | diff to current |
2014-09-23 |
jkummerow@chromium.org | Fix method dispatch in Keyed/StoreIC, and JumpIfNotUniq... |
blob | commitdiff | raw | diff to current |
2014-09-17 |
svenpanne@chromium.org | Fixed deopt reasons in TaggedToI. |
blob | commitdiff | raw | diff to current |
2014-09-10 |
yangguo@chromium.org | Rename ascii to one-byte where applicable. |
blob | commitdiff | raw | diff to current |
2014-09-08 |
bmeurer@chromium.org | Replace our home-grown BitCast with bit_cast from Chrom... |
blob | commitdiff | raw | diff to current |
2014-09-05 |
svenpanne@chromium.org | Generalized division via multiplication. |
blob | commitdiff | raw | diff to current |
2014-09-02 |
bmeurer@chromium.org | First step to cleanup the power-of-2 mess. |
blob | commitdiff | raw | diff to current |
2014-09-02 |
yangguo@chromium.org | Minor-key-ify four stubs. |
blob | commitdiff | raw | diff to current |
2014-08-05 |
jochen@chromium.org | Move a bunch of GC related files to heap/ subdirectory |
blob | commitdiff | raw | diff to current |
2014-08-04 |
bmeurer@chromium.org | Rename ASSERT* to DCHECK*. |
blob | commitdiff | raw | diff to current |
2014-07-29 |
verwaest@chromium.org | Clean up name distinction between Keyed ICs and Element... |
blob | commitdiff | raw | diff to current |
2014-07-29 |
mstarzinger@chromi... | Support for dynamic write-barrier counters everywhere. |
blob | commitdiff | raw | diff to current |
2014-07-23 |
verwaest@chromium.org | Only to the relevant checks in LoadFunctionPrototype |
blob | commitdiff | raw | diff to current |
2014-07-14 |
mvstanton@chromium.org | Use register parameters in ElementsTransitionGenerator. |
blob | commitdiff | raw | diff to current |
2014-07-01 |
ishell@chromium.org | Reland r22082 "Replace HeapNumber as doublebox with... |
blob | commitdiff | raw | diff to current |
2014-06-30 |
jochen@chromium.org | Move platform abstraction to base library |
blob | commitdiff | raw | diff to current |
2014-06-30 |
ishell@chromium.org | Revert "Replace HeapNumber as doublebox with an explici... |
blob | commitdiff | raw | diff to current |
2014-06-30 |
ishell@chromium.org | Replace HeapNumber as doublebox with an explicit Mutabl... |
blob | commitdiff | raw | diff to current |
2014-06-25 |
danno@chromium.org | Remove distinction between hidden and normal runtime... |
blob | commitdiff | raw | diff to current |
2014-06-24 |
haitao.feng@intel.com | Change some cmpq to cmpp, times_8 to times_pointer_size... |
blob | commitdiff | raw | diff to current |
2014-06-20 |
mstarzinger@chromi... | Check alpha-sorting of includes during presubmit. |
blob | commitdiff | raw | diff to current |
2014-06-10 |
haitao.feng@intel.com | Update SmiShiftLeft, SmiShiftLogicalRight, SmiShiftArit... |
blob | commitdiff | raw | diff to current |
2014-06-04 |
haitao.feng@intel.com | Introduce MakeSureDoubleAlignedHelper for x64 port. |
blob | commitdiff | raw | diff to current |
2014-06-03 |
bmeurer@chromium.org | Improve write barriers in optimized code. |
blob | commitdiff | raw | diff to current |
2014-06-03 |
jochen@chromium.org | Use full include paths everywhere |
blob | commitdiff | raw | diff to current |
2014-05-30 |
verwaest@chromium.org | Don't push eax/rax before calling Runtime_Abort |
blob | commitdiff | raw | diff to current |
2014-05-27 |
danno@chromium.org | Convert String array index/length hash to BitField |
blob | commitdiff | raw | diff to current |
2014-05-27 |
danno@chromium.org | Convert ElementsKind into a BitField |
blob | commitdiff | raw | diff to current |
2014-05-27 |
bmeurer@chromium.org | Avoid HeapObject check in HStoreNamedField. |
blob | commitdiff | raw | diff to current |
2014-05-26 |
hpayer@chromium.org | Remove high promotion mode. |
blob | commitdiff | raw | diff to current |
2014-05-26 |
bmeurer@chromium.org | LoadUint32() doesn't need a scratch register. |
blob | commitdiff | raw | diff to current |
2014-05-16 |
yangguo@chromium.org | Decouple CpuFeatures from serializer state. |
blob | commitdiff | raw | diff to current |
2014-05-15 |
yangguo@chromium.org | Refactor MacroAssembler::Prologue. |
blob | commitdiff | raw | diff to current |
2014-05-12 |
yangguo@chromium.org | Clean up debugger flags. |
blob | commitdiff | raw | diff to current |
2014-05-09 |
verwaest@chromium.org | Reland and fix r21225 and r21226 |
blob | commitdiff | raw | diff to current |
2014-05-09 |
ishell@chromium.org | [Sheriff] This reverts commits r21225 and r21226 for... |
blob | commitdiff | raw | diff to current |
2014-05-09 |
verwaest@chromium.org | Make BitField3 a raw uint32 field, and move to the... |
blob | commitdiff | raw | diff to current |
2014-05-06 |
mstarzinger@chromi... | Remove broken %_Log functionality. |
blob | commitdiff | raw | diff to current |
2014-04-30 |
svenpanne@chromium.org | Added a Isolate* parameter to Serializer::enabled(). |
blob | commitdiff | raw | diff to current |
2014-04-30 |
haitao.feng@intel.com | Introduce DropUnderReturnAddress for x64 port. |
blob | commitdiff | raw | diff to current |
2014-04-30 |
haitao.feng@intel.com | Introduce PushQuad and PopQuad for x64 port. |
blob | commitdiff | raw | diff to current |
2014-04-30 |
haitao.feng@intel.com | Update SafeMove, SafePush, SmiToIndex and SmiToNegative... |
blob | commitdiff | raw | diff to current |
2014-04-29 |
bmeurer@chromium.org | Bulk update of Google copyright headers in source files. |
blob | commitdiff | raw | diff to current |
2014-04-28 |
ulan@chromium.org | Convert function.name to API-style accessor and make... |
blob | commitdiff | raw | diff to current |
next |