Remove ASSERT_SIZE in favor of the safer DEFINE_SIZE_STATIC
[framework/uifw/harfbuzz.git] / src / hb-ot-layout-gsubgpos-private.hh
2010-05-10 Behdad EsfahbodRemove ASSERT_SIZE in favor of the safer DEFINE_SIZE_STATIC
2010-05-10 Behdad EsfahbodCleanup ASSERT_SIZE_VAR
2010-05-06 Behdad EsfahbodStart cleaning up get_size()
2010-05-06 Behdad EsfahbodRemove the last of SANITIZE macros: SANITIZE_SELF
2010-05-06 Behdad EsfahbodRemove SANITIZE macro
2010-05-06 Behdad EsfahbodRemove SANITIZE_WITH_BASE
2010-05-06 Behdad EsfahbodRemove SANITIZE_MEM
2010-05-06 Behdad EsfahbodRemove SANITIZE_ARRAY
2010-05-05 Behdad EsfahbodCosmetic
2010-05-05 Behdad EsfahbodMinor
2010-05-05 Behdad EsfahbodSimplify chaining
2010-05-05 Behdad EsfahbodRemove APPLY_ARG_DEF and APPLY_ARG
2010-05-05 Behdad EsfahbodPort apply to use hb_trace_t
2010-05-05 Behdad EsfahbodMove context_length into apply_context
2010-05-05 Behdad EsfahbodMove buffer into apply_context
2010-05-05 Behdad EsfahbodMove layout_context into apply_context
2010-05-05 Behdad EsfahbodMinor
2010-05-05 Behdad EsfahbodRemove SANITIZE_ARG_DEF and SANITIZE_ARG
2010-05-04 Behdad EsfahbodRemove SANITIZE_THIS
2010-05-04 Behdad EsfahbodRemove SANITIZE_THIS2
2010-05-04 Behdad EsfahbodCosmetic
2010-05-04 Behdad EsfahbodRemove SANITIZE_THIS3
2010-05-04 Behdad EsfahbodCosmetic: Rename HB_LIKELY/HB_UNLIKELY to likely/unlikely
2010-04-29 Behdad EsfahbodRename HB_GNUC_UNUSED -> HB_UNUSED
2010-04-29 Behdad EsfahbodDefine HB_FUNC for portability to non-gcc
2010-04-29 Behdad EsfahbodRename apply_context -> context
2010-04-29 Behdad EsfahbodRename
2010-04-29 Behdad Esfahbod[apply] Use a context object to reduce number of parame...
2010-04-29 Behdad EsfahbodFurther simplify tracing
2010-04-29 Behdad EsfahbodSimplify trace code
2010-04-29 Behdad Esfahbod[sanitize] Make debug code always available to the...
2010-04-28 Behdad Esfahbod[gsubgpos] Make debug code always available to the...
2010-04-28 Behdad EsfahbodFix debug build
2010-04-23 Behdad EsfahbodRemove GET_FOR_DATA macros
2010-04-22 Behdad EsfahbodCosmetic
2010-04-22 Behdad EsfahbodConvert the last set of cast macros to templates
2010-04-22 Behdad EsfahbodCleanup Extension sanitize()
2010-04-22 Behdad EsfahbodFail sanitize on major version mismatch
2010-04-22 Behdad EsfahbodCleanup ContextFormat3 sanitize
2010-04-22 Behdad EsfahbodSimplify Extension offset now that our int types have...
2010-04-22 Behdad EsfahbodChange header comment
2010-04-22 Behdad EsfahbodRename ConstCharP to CharP (overloaded now)
2010-04-22 Behdad EsfahbodRename const_array() to array() (overloaded)
2010-04-21 Behdad EsfahbodConvert NEXT() and ARRAY_AFTER() macros to templates
2010-04-21 Behdad EsfahbodUse templates for const char * casts
2010-04-21 Behdad EsfahbodConst correctness
2010-04-21 Behdad EsfahbodFix warnings
2010-04-21 Behdad EsfahbodFix debug build
2010-04-21 Behdad EsfahbodFix the mystery bug!
2009-11-05 Behdad EsfahbodInclude stdio.h if debugging
2009-11-04 Behdad EsfahbodFix array query API
2009-11-03 Behdad EsfahbodDon't use zero-sized arrays
2009-11-02 Behdad Esfahbod[HB] Add comment
2009-11-02 Behdad Esfahbod[HB] Fix apply_lookup() loop
2009-11-02 Behdad Esfahbod[HB] Fix bug in chain_context_lookup() invocations
2009-11-02 Behdad Esfahbod[HB] Rename DEBUG to TRACE where appropriate
2009-11-02 Behdad Esfahbod[HB] Add GSUB/GPOS tracing
2009-11-02 Behdad Esfahbod[HB] Put C++ inline's back
2009-11-02 Behdad Esfahbod[HB] Add a NEXT() macro
2009-11-02 Behdad Esfahbod[HB] Remove clumsy macros and improve API
2009-11-02 Behdad Esfahbod[HB] Remove a few 'inline's, though the compiler mostly...
2009-11-02 Behdad Esfahbod[HB] Add sanitize debugging facilities
2009-11-02 Behdad Esfahbod[HB] Minor cleanup
2009-11-02 Behdad Esfahbod[HB] GDEF sanitize()
2009-11-02 Behdad Esfahbod[HB] Fix Extension sanitize()
2009-11-02 Behdad Esfahbod[HB] More cast cleanup
2009-11-02 Behdad Esfahbod[Hb] Use reinterpret casts instead of direct casts...
2009-11-02 Behdad Esfahbod[HB] More sanitize()
2009-11-02 Behdad Esfahbod[HB] Start sanitize()
2009-11-02 Behdad Esfahbod[HB] Use face_t directly instead of ot_layout_t
2009-11-02 Behdad Esfahbod[OT] Rename C++ header files from *.h to *.hh