tizen: packaging: build on x86_64 arm64 and others too
[platform/upstream/iotivity.git] / tools / tizen / iotivity.spec
index 7f4358c..1cea601 100644 (file)
@@ -35,7 +35,15 @@ developing applications that use %{name}.
 %ifarch %arm
 export RPM_ARCH=arm
 %else
+%ifarch aarch64
+export RPM_ARCH=arm64
+%else
+%ifarch i586 i686 %{ix86}
 export RPM_ARCH=x86
+%else
+export RPM_ARCH=%{_arch}
+%endif
+%endif
 %endif
 
 scons -j 4 TARGET_ARCH=$RPM_ARCH