riscv64: Add support for RISC-V
[platform/upstream/iotivity.git] / tools / tizen / iotivity-vd-tv-tizen30.spec
index 557c55d..6568be1 100644 (file)
@@ -35,6 +35,7 @@ Source1002: %{name}-test.manifest
 # For Example
 %if %{RELEASE} == "True"
 %define build_mode release
+%define log_level INFO
 %else
 %define build_mode debug
 %endif
@@ -45,6 +46,9 @@ Source1002: %{name}-test.manifest
 %ifarch aarch64
 %define TARGET_ARCH "arm64"
 %endif
+%ifarch riscv64
+%define TARGET_ARCH "riscv64"
+%endif
 %ifarch x86_64
 %define TARGET_ARCH "x86_64"
 %endif
@@ -84,6 +88,7 @@ Source1002: %{name}-test.manifest
 %{!?BLE_CUSTOM_ADV: %define BLE_CUSTOM_ADV False}
 %{!?BLE_DIVISION: %define BLE_DIVISION VD}
 %{!?BLE_TIZEN_30: %define BLE_TIZEN_30 True}
+%{!?DISABLE_BLE_SERVER: %define DISABLE_BLE_SERVER 0}
 %{!?MULTIPLE_OWNER: %define MULTIPLE_OWNER 0}
 
 BuildRequires:  expat-devel
@@ -101,7 +106,6 @@ BuildRequires:  pkgconfig(sqlite3)
 BuildRequires:  gettext-tools
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(capi-network-connection)
-BuildRequires:  pkgconfig(capi-network-wifi)
 BuildRequires:  pkgconfig(capi-network-bluetooth) >= 0.1.52
 %else
 %if 0%{?fedora:1}
@@ -181,7 +185,9 @@ scons %{JOB} --prefix=%{_prefix} \
     BLE_CUSTOM_ADV=%{BLE_CUSTOM_ADV} \
     BLE_DIVISION=%{BLE_DIVISION} \
     BLE_TIZEN_30=%{BLE_TIZEN_30} \
+    DISABLE_BLE_SERVER=%{DISABLE_BLE_SERVER} \
     MULTIPLE_OWNER=%{MULTIPLE_OWNER} \
+    LOG_LEVEL=%{log_level} \
     #eol
 
 %install