Upstream version 8.36.161.0
[platform/framework/web/crosswalk.git] / src / xwalk / packaging / crosswalk.spec
index f3cad41..139de2d 100644 (file)
@@ -1,8 +1,22 @@
 %bcond_with x
 %bcond_with wayland
 
+%ifarch x86_64 %{arm}
+### x86_64
+# NaCl build on 64bit system require libc 32bit to build the 32 IRT.
+# While Tizen 64bit image does not offer 32bit packages at all,
+# check https://bugs.tizen.org/jira/browse/PTREL-803 for details.
+# So disable nacl for 64bit now.
+### ARM
+# Due to OBS build for ARM some files needed by NaCl to be build
+# are not present.
+%define _disable_nacl 1
+%else
+%define _disable_nacl 0
+%endif
+
 Name:           crosswalk
-Version:        6.35.121.0
+Version:        8.36.161.0
 Release:        0
 Summary:        Crosswalk is an app runtime based on Chromium
 License:        (BSD-3-Clause and LGPL-2.1+)
@@ -15,16 +29,17 @@ Source3:        xwalk.service.in
 Source1001:     crosswalk.manifest
 Source1002:     %{name}.xml.in
 Source1003:     %{name}.png
-Patch1:         %{name}-do-not-look-for-gtk2-when-using-aura.patch
-Patch2:         %{name}-no-fatal-ld-warnings.patch
 Patch9:         Blink-Add-GCC-flag-Wno-narrowing-fix-64bits-build.patch
+Patch10:        crosswalk-do-not-look-for-gtk-dependencies-on-x11.patch
 
 BuildRequires:  bison
 BuildRequires:  bzip2-devel
+BuildRequires:  elfutils
 BuildRequires:  expat-devel
 BuildRequires:  flex
 BuildRequires:  gperf
 BuildRequires:  libcap-devel
+BuildRequires:  libelf-devel
 BuildRequires:  ninja
 BuildRequires:  python
 BuildRequires:  python-xml
@@ -45,11 +60,13 @@ BuildRequires:  pkgconfig(libdrm)
 BuildRequires:  pkgconfig(libexif)
 BuildRequires:  pkgconfig(libpci)
 BuildRequires:  pkgconfig(libpulse)
+BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(libudev)
 BuildRequires:  pkgconfig(libxml-2.0)
 BuildRequires:  pkgconfig(libxslt)
 BuildRequires:  pkgconfig(pango)
 BuildRequires:  pkgconfig(pkgmgr-info)
+BuildRequires:  pkgconfig(pkgmgr-installer)
 BuildRequires:  pkgconfig(pkgmgr-parser)
 BuildRequires:  pkgconfig(nspr)
 BuildRequires:  pkgconfig(nss)
@@ -105,15 +122,13 @@ cp -a src/AUTHORS AUTHORS.chromium
 cp -a src/LICENSE LICENSE.chromium
 cp -a src/xwalk/LICENSE LICENSE.xwalk
 
-%patch1
+%patch9
 
-# Linking fails in Tizen Common when fatal ld warnings are enabled. XWALK-1379.
-%if "%{profile}" == "common" || "%{profile}" == "generic"
-%patch2
+# The profiles using Wayland (and thus Ozone) do not need this patch.
+%if !%{with wayland}
+%patch10
 %endif
 
-%patch9
-
 %build
 
 # For ffmpeg on ia32. The original CFLAGS set by the gyp and config files in
@@ -121,6 +136,15 @@ cp -a src/xwalk/LICENSE LICENSE.xwalk
 # CFLAGS end up appending -fno-omit-frame-pointer. See http://crbug.com/37246
 export CFLAGS=`echo $CFLAGS | sed s,-fno-omit-frame-pointer,,g`
 
+%if ! %{_disable_nacl}
+# For nacl_bootstrap on ia32. The original CFLAGS set by the gyp
+# native_client/src/trusted/service_runtime/linux/nacl_bootstrap.gyp already ignored 
+# -fstack-protector and -funwind-tables, but Tizen's CFLAGS end up appending them, thus
+# causing linking failures. Check XWALK-1689 for details.
+export CFLAGS=`echo $CFLAGS | sed s,-fstack-protector,,g`
+export CFLAGS=`echo $CFLAGS | sed s,-funwind-tables,,g`
+%endif
+
 # Building the RPM in the GBS chroot fails with errors such as
 #   /usr/lib/gcc/i586-tizen-linux/4.7/../../../../i586-tizen-linux/bin/ld:
 #       failed to set dynamic section sizes: Memory exhausted
@@ -141,7 +165,32 @@ if [ -n "${BUILDDIR_NAME}" ]; then
 fi
 
 %if %{with wayland}
-GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Duse_ozone=1 -Denable_ozone_wayland_vkb=1"
+GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Duse_ozone=1 -Denable_ozone_wayland_vkb=1 -Denable_xdg_shell=0"
+%endif
+
+GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_nacl=%{_disable_nacl}"
+
+# Linking fails in Tizen Common when fatal ld warnings are enabled. XWALK-1379.
+%if "%{profile}" == "common" || "%{profile}" == "generic"
+GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Ddisable_fatal_linker_warnings=1"
+%endif
+
+# For building for arm in OBS, we need :
+# -> to unset sysroot value.
+# sysroot variable is automatically set for cross compilation to use arm-sysroot provided by Chromium project
+# -> to force system ld binary.
+# Indeed the build is made on Emulated / Virtualized environment that correspond
+# to the target.
+# gold ld used is avaible only for 32/64 bits Intel Arch.
+# sysroot usage is not needed, we need to use arm libraries from the virtualized environment.
+#
+# Crosswalk build fails if the fpu selected in the gcc option is different from neon in case of arm7 compilation
+# So force it.
+%ifarch %{arm}
+GYP_EXTRA_FLAGS="${GYP_EXTRA_FLAGS} -Dsysroot= -Dlinux_use_gold_binary=0"
+export CFLAGS=`echo $CFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
+export CXXFLAGS=`echo $CXXFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
+export FFLAGS=`echo $FFLAGS | sed s,-mfpu=vfpv3,-mfpu=neon,g`
 %endif
 
 # --no-parallel is added because chroot does not mount a /dev/shm, this will
@@ -151,7 +200,6 @@ export GYP_GENERATORS='ninja'
 --no-parallel \
 ${GYP_EXTRA_FLAGS} \
 -Dchromeos=0 \
--Ddisable_nacl=1 \
 -Dtizen=1 \
 -Dpython_ver=2.7 \
 -Duse_aura=1 \
@@ -180,10 +228,21 @@ install -m 06755 -p -D src/out/Release/xwalk-pkg-helper %{buildroot}%{_bindir}/x
 
 # Supporting libraries and resources.
 install -p -D src/out/Release/icudtl.dat %{buildroot}%{_libdir}/xwalk/icudtl.dat
-install -p -D src/out/Release/lib/libmojo_system.so %{buildroot}%{_libdir}/xwalk/lib/libmojo_system.so
 install -p -D src/out/Release/libffmpegsumo.so %{buildroot}%{_libdir}/xwalk/libffmpegsumo.so
 install -p -D src/out/Release/xwalk.pak %{buildroot}%{_libdir}/xwalk/xwalk.pak
 
+# PNaCl
+%if ! %{_disable_nacl}
+install -p -D src/out/Release/libppGoogleNaClPluginChrome.so %{buildroot}%{_libdir}/xwalk/libppGoogleNaClPluginChrome.so
+install -p -D src/out/Release/nacl_bootstrap_munge_phdr %{buildroot}%{_libdir}/xwalk/nacl_bootstrap_munge_phdr
+install -p -D src/out/Release/nacl_bootstrap_raw %{buildroot}%{_libdir}/xwalk/nacl_bootstrap_raw
+install -p -D src/out/Release/nacl_helper %{buildroot}%{_libdir}/xwalk/nacl_helper
+install -p -D src/out/Release/nacl_helper_bootstrap %{buildroot}%{_libdir}/xwalk/nacl_helper_bootstrap
+install -p -D src/out/Release/nacl_irt_*.nexe %{buildroot}%{_libdir}/xwalk
+install -p -d %{buildroot}%{_libdir}/xwalk/pnacl
+install -m 0664 -p -D src/out/Release/pnacl/* %{buildroot}%{_libdir}/xwalk/pnacl
+%endif
+
 # Register xwalk to the package manager.
 install -p -D %{name}.xml %{buildroot}%{_manifestdir}/%{name}.xml
 install -p -D %{name}.png %{buildroot}%{_desktop_icondir}/%{name}.png
@@ -200,8 +259,16 @@ mkdir -p %{_manifestdir_ro}
 %{_bindir}/xwalk-launcher
 %{_bindir}/xwalk-pkg-helper
 %{_libdir}/xwalk/icudtl.dat
-%{_libdir}/xwalk/lib/libmojo_system.so
 %{_libdir}/xwalk/libffmpegsumo.so
+%if ! %{_disable_nacl}
+%{_libdir}/xwalk/libppGoogleNaClPluginChrome.so
+%{_libdir}/xwalk/nacl_bootstrap_munge_phdr
+%{_libdir}/xwalk/nacl_bootstrap_raw
+%{_libdir}/xwalk/nacl_helper
+%{_libdir}/xwalk/nacl_helper_bootstrap
+%{_libdir}/xwalk/nacl_irt_*.nexe
+%{_libdir}/xwalk/pnacl/*
+%endif
 %{_libdir}/xwalk/xwalk
 %{_libdir}/xwalk/xwalk.pak
 %{_manifestdir}/%{name}.xml