Fix invalid licenses
[platform/framework/web/crosswalk-tizen.git] / packaging / wrt.spec
index 520efa9..ae5cc22 100755 (executable)
@@ -6,12 +6,13 @@ Summary:    Runtime for Web Application
 Version:    2.0.0
 Release:    1
 Group:      Development/Libraries
-License:    Apache License, Version 2.0 / BSD
-URL:        N/A
+License:    Apache-2.0 and BSD-3-Clause
+URL:        https://www.tizen.org
 Source0:    %{name}-%{version}.tar.gz
 
 BuildRequires: cmake
 BuildRequires: edje-tools
+BuildRequires: gettext
 BuildRequires: pkgconfig(appsvc)
 BuildRequires: pkgconfig(bundle)
 BuildRequires: pkgconfig(dlog)
@@ -27,7 +28,10 @@ BuildRequires: pkgconfig(cert-svc)
 BuildRequires: pkgconfig(uuid)
 BuildRequires: pkgconfig(gio-2.0)
 BuildRequires: pkgconfig(aul)
+BuildRequires: pkgconfig(ecore)
+BuildRequires: pkgconfig(notification)
 BuildRequires: boost-devel
+BuildRequires: python
 %if %{with x}
 BuildRequires: pkgconfig(ecore-x)
 %endif
@@ -36,7 +40,7 @@ BuildRequires: pkgconfig(ecore-wayland)
 %endif
 
 #web-engine
-BuildRequires:  pkgconfig(chromium-efl)
+BuildRequires: pkgconfig(chromium-efl)
 
 %description
 Runtime for Web Application
@@ -44,13 +48,11 @@ Runtime for Web Application
 %prep
 %setup -q
 
+%define extension_path %{_libdir}/tizen-extensions-crosswalk
+
 %build
 
-%ifarch %{arm}
-%define build_dir build-arm
-%else
-%define build_dir build-x86
-%endif
+%define build_dir cmake_build_dir
 
 %if %{with x}
 %define enable_x11 On
@@ -68,13 +70,19 @@ mkdir -p %{build_dir}
 cd %{build_dir}
 
 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+         -DLIB_INSTALL_DIR=%{_libdir} \
          -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
          -DX11_SUPPORT=%{enable_x11} \
-         -DWAYLAND_SUPPORT=%{enable_wayland}
+         -DWAYLAND_SUPPORT=%{enable_wayland} \
+         -DEXTENSION_PATH=%{extension_path}
 
 make %{?jobs:-j%jobs}
 
 %install
+%define license_dir %{build_dir}%{_datadir}/license 
+mkdir -p %{license_dir} 
+cp LICENSE %{license_dir}/%{name} 
+cat LICENSE.BSD >> %{license_dir}/%{name}
 cd %{build_dir}
 %make_install
 
@@ -83,6 +91,8 @@ rm -fr %{buildroot}
 
 %files
 %attr(755,root,root) %{_bindir}/wrt
-%attr(755,root,root) %{_bindir}/wrt-extension
+%attr(755,root,root) %{_bindir}/wrt-popup-test
 %attr(644,root,root) %{_datadir}/edje/wrt/wrt.edj
 %attr(644,root,root) %{_libdir}/libwrt-injected-bundle.so
+%attr(644,root,root) %{extension_path}/libwidget-plugin.so
+%attr(755,root,root) %{_datadir}/locale/*