Fix invalid licenses
[platform/framework/web/crosswalk-tizen.git] / packaging / wrt.spec
index 40198e4..ae5cc22 100755 (executable)
@@ -6,7 +6,7 @@ Summary:    Runtime for Web Application
 Version:    2.0.0
 Release:    1
 Group:      Development/Libraries
-License:    BSD-3-Clause and Apache-2.0
+License:    Apache-2.0 and BSD-3-Clause
 URL:        https://www.tizen.org
 Source0:    %{name}-%{version}.tar.gz
 
@@ -48,13 +48,11 @@ Runtime for Web Application
 %prep
 %setup -q
 
+%define extension_path %{_libdir}/tizen-extensions-crosswalk
+
 %build
 
-%ifarch %{arm}
-%define build_dir build-arm
-%else
-%define build_dir build-x86
-%endif
+%define build_dir cmake_build_dir
 
 %if %{with x}
 %define enable_x11 On
@@ -72,13 +70,19 @@ mkdir -p %{build_dir}
 cd %{build_dir}
 
 cmake .. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+         -DLIB_INSTALL_DIR=%{_libdir} \
          -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
          -DX11_SUPPORT=%{enable_x11} \
-         -DWAYLAND_SUPPORT=%{enable_wayland}
+         -DWAYLAND_SUPPORT=%{enable_wayland} \
+         -DEXTENSION_PATH=%{extension_path}
 
 make %{?jobs:-j%jobs}
 
 %install
+%define license_dir %{build_dir}%{_datadir}/license 
+mkdir -p %{license_dir} 
+cp LICENSE %{license_dir}/%{name} 
+cat LICENSE.BSD >> %{license_dir}/%{name}
 cd %{build_dir}
 %make_install
 
@@ -90,5 +94,5 @@ rm -fr %{buildroot}
 %attr(755,root,root) %{_bindir}/wrt-popup-test
 %attr(644,root,root) %{_datadir}/edje/wrt/wrt.edj
 %attr(644,root,root) %{_libdir}/libwrt-injected-bundle.so
-%attr(644,root,root) %{_libdir}/tizen-extensions-crosswalk/libwidget-plugin.so
+%attr(644,root,root) %{extension_path}/libwidget-plugin.so
 %attr(755,root,root) %{_datadir}/locale/*