Merge "fix: use EINA_* booleans instread of TRUE/FALSE" into tizen
[platform/framework/web/wrt.git] / packaging / wrt.spec
index ea6ba8d..079c9a2 100644 (file)
@@ -1,3 +1,4 @@
+%bcond_with x
 %bcond_with mesa
 %bcond_with wayland
 %bcond_with decrypt
@@ -5,8 +6,8 @@
 
 Name:       wrt
 Summary:    web runtime
-Version:    0.8.277
-Release:    1
+Version:    0.8.288
+Release:    0
 Group:      Development/Libraries
 License:    Apache-2.0
 URL:        N/A
@@ -20,6 +21,7 @@ Source1001:   wrt.manifest
 BuildRequires:  cmake
 BuildRequires:  gettext
 BuildRequires:  edje-tools
+BuildRequires:  pkgconfig(ail)
 BuildRequires:  pkgconfig(aul)
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(ewebkit2)
@@ -30,7 +32,10 @@ BuildRequires:  pkgconfig(libpcrecpp)
 BuildRequires:  pkgconfig(ecore)
 BuildRequires:  pkgconfig(eina)
 BuildRequires:  pkgconfig(ui-gadget-1)
+BuildRequires:  pkgconfig(libcurl)
+%if %{with x}
 BuildRequires:  pkgconfig(utilX)
+%endif
 BuildRequires:  pkgconfig(secure-storage)
 BuildRequires:  pkgconfig(pkgmgr)
 BuildRequires:  pkgconfig(libiri)
@@ -52,8 +57,9 @@ BuildRequires:  pkgconfig(wrt-plugins-ipc-message)
 BuildRequires:  pkgconfig(wrt-popup-wrt-runner)
 BuildRequires:  pkgconfig(wrt-popup-ace-runner)
 BuildRequires:  pkgconfig(sysman)
-BuildRequires:  pkgconfig(app2sd)
 BuildRequires:  pkgconfig(capi-system-system-settings)
+BuildRequires:  pkgconfig(app2sd)
+BuildRequires:  pkgconfig(libtzplatform-config)
 %if %{with mesa}
 BuildRequires: pkgconfig(gl)
 BuildRequires: pkgconfig(glesv2)
@@ -64,10 +70,12 @@ Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  pkgconfig(libsmack)
 BuildRequires:  pkgconfig(efl-assist)
+BuildRequires:  pkgconfig(pkgmgr-info)
 BuildRequires:  libss-client-devel
 BuildRequires:  gettext
 BuildRequires:  edje-tools
 Requires: libss-client
+Requires: libtzplatform-config
 
 ## wrt-launchpad-daemon #######################################################
 BuildRequires:  pkgconfig(app-checker)
@@ -144,13 +152,9 @@ make %{?jobs:-j%jobs}
 %install
 mkdir -p %{buildroot}/usr/share/license
 cp LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
-cp LICENSE.Flora %{buildroot}/usr/share/license/%{name}
+cat LICENSE.Flora >> %{buildroot}/usr/share/license/%{name}
 %make_install
 
-## wrt-launchpad-daemon #######################################################
-
-#systemd
-
 %if %{with multi_user}
 mkdir -p %{buildroot}%{_unitdir_user}/tizen-middleware.target.wants/
 install -m 0644 %SOURCE102 %{buildroot}%{_unitdir_user}/wrt_launchpad_daemon.service
@@ -163,23 +167,23 @@ ln -s %{_unitdir}/wrt_launchpad_daemon_1.socket %{buildroot}%{_unitdir}/sockets.
 ln -s %{_unitdir}/wrt_launchpad_daemon_2.socket %{buildroot}%{_unitdir}/sockets.target.wants/wrt_launchpad_daemon_2.socket
 %endif
 
-%preun
-if [ $1 == 0 ]; then
+%pre
+if [ $1 -eq 2 ] ; then
 %if %{with multi_user}
-       systemctl --user stop wrt_launchpad_daemon.service
+    systemctl --user stop wrt_launchpad_daemon@app.service wrt_launchpad_daemon_1.socket wrt_launchpad_daemon_2.socket
 %else
-       systemctl stop wrt_launchpad_daemon@app.service
+    systemctl stop wrt_launchpad_daemon@app.service wrt_launchpad_daemon_1.socket wrt_launchpad_daemon_2.socket
 %endif
-
 fi
 
-
-
-
-###############################################################################
-
-
-
+%preun
+if [ $1 -eq 0 ] ; then
+%if %{with multi_user}
+    systemctl --user stop wrt_launchpad_daemon@app.service wrt_launchpad_daemon_1.socket wrt_launchpad_daemon_2.socket
+%else
+    systemctl stop wrt_launchpad_daemon@app.service wrt_launchpad_daemon_1.socket wrt_launchpad_daemon_2.socket
+%endif
+fi
 
 %clean
 rm -rf %{buildroot}
@@ -188,28 +192,18 @@ rm -rf %{buildroot}
 /sbin/ldconfig
 chmod +s /usr/bin/wrt-launcher
 
-## wrt-launchpad-daemon #######################################################
-#systemd
 /sbin/ldconfig
 systemctl daemon-reload
-if [ $1 == 1 ]; then
+if [ $1 -eq 2 ] ; then
 %if %{with multi_user}
-    systemctl --user restart wrt_launchpad_daemon.service
+    systemctl --user start wrt_launchpad_daemon@app.service
 %else
-    systemctl restart wrt_launchpad_daemon@app.service
+    systemctl start wrt_launchpad_daemon@app.service
 %endif
-
-
 fi
-###############################################################################
-
-echo "[WRT] wrt postinst done ..."
 
-## wrt-launchpad-daemon #######################################################
-#systemd
 %postun -p /sbin/ldconfig
 systemctl daemon-reload
-###############################################################################
 
 %files
 %manifest %{name}.manifest
@@ -232,8 +226,6 @@ systemctl daemon-reload
 ## wrt-launchpad-daemon #######################################################
 %attr(755,root,root) %{_bindir}/wrt_launchpad_daemon
 /usr/share/aul/preload_list_wrt.txt
-/etc/smack/accesses2.d/wrt_launchpad_daemon.rule
-/opt/etc/smack/accesses.d/wrt_launchpad_daemon.rule
 #systemd
 %if %{with multi_user}
 %{_unitdir_user}/tizen-middleware.target.wants/wrt_launchpad_daemon.service