[Release] wrt-installer_0.1.114
[framework/web/wrt-installer.git] / packaging / wrt-installer.spec
index 6d3237b..1cf31d6 100644 (file)
@@ -1,7 +1,7 @@
 #git:framework/web/wrt-installer
 Name:       wrt-installer
 Summary:    Installer for tizen Webruntime
-Version:    0.1.86
+Version:    0.1.114
 Release:    1
 Group:      Development/Libraries
 License:    Apache License, Version 2.0
@@ -19,6 +19,7 @@ BuildRequires:  pkgconfig(dpl-event-efl)
 BuildRequires:  pkgconfig(dpl-utils-efl)
 BuildRequires:  pkgconfig(dpl-wrt-dao-ro)
 BuildRequires:  pkgconfig(dpl-wrt-dao-rw)
+BuildRequires:  pkgconfig(wrt-commons-i18n-dao-ro)
 BuildRequires:  pkgconfig(security-install)
 BuildRequires:  pkgconfig(ecore-x)
 BuildRequires:  pkgconfig(xmlsec1)
@@ -36,7 +37,6 @@ BuildRequires:  pkgconfig(utilX)
 BuildRequires:  pkgconfig(wrt-plugins-types)
 BuildRequires:  pkgconfig(tapi)
 BuildRequires:  pkgconfig(shortcut)
-BuildRequires:  pkgconfig(dpl-encryption)
 BuildRequires:  pkgconfig(capi-appfw-app-manager)
 BuildRequires:  pkgconfig(app2sd)
 BuildRequires:  pkgconfig(web-provider)
@@ -59,6 +59,11 @@ Description: Wrt Installer for Tizen apps and Wac apps
 %endif
 
 %build
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="$CFLAGS -DTIZEN_ENGINEER_MODE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_ENGINEER_MODE"
+export FFLAGS="$FFLAGS -DTIZEN_ENGINEER_MODE"
+%endif
 
 export LDFLAGS+="-Wl,--rpath=/usr/lib -Wl,--hash-style=both -Wl,--as-needed"
 LDFLAGS="$LDFLAGS"
@@ -87,7 +92,16 @@ rm -rf %{buildroot}
 chmod +s /usr/bin/wrt-installer
 
 #symlink for package manager
-ln -sf /usr/bin/wrt-installer /usr/etc/package-manager/backend/wgt
+%define pkg_manager_backend_path "/usr/etc/package-manager/backend"
+ln -sf /usr/bin/wrt-installer %{pkg_manager_backend_path}/wgt
+ln -sf %{pkg_manager_backend_path}/wgt %{pkg_manager_backend_path}/Wgt
+ln -sf %{pkg_manager_backend_path}/wgt %{pkg_manager_backend_path}/wGt
+ln -sf %{pkg_manager_backend_path}/wgt %{pkg_manager_backend_path}/wgT
+ln -sf %{pkg_manager_backend_path}/wgt %{pkg_manager_backend_path}/WGt
+ln -sf %{pkg_manager_backend_path}/wgt %{pkg_manager_backend_path}/wGT
+ln -sf %{pkg_manager_backend_path}/wgt %{pkg_manager_backend_path}/WgT
+ln -sf %{pkg_manager_backend_path}/wgt %{pkg_manager_backend_path}/WGT
+
 
 #for booting recovery
 mkdir -p /opt/share/widget/temp_info
@@ -110,4 +124,3 @@ mkdir -p /opt/share/icons/default/small
     %attr(755,root,root) %{_bindir}/wrt-installer-tests-*
     /opt/share/widget/tests/installer/widgets/*
 %endif
-%{_datadir}/wrt-engine/default_icon_tizen.png