Release version 0.15.34
[platform/core/appfw/wgt-backend.git] / packaging / wgt-backend.spec
index 91555d7..859c239 100644 (file)
@@ -1,6 +1,6 @@
 Name:           wgt-backend
 Summary:        Application installer backend for WGT
-Version:        0.15.8
+Version:        0.15.34
 Release:        1
 Group:          Application Framework/Package Management
 License:        Apache-2.0
@@ -13,7 +13,6 @@ Source1002:     wgt-installer-tests.manifest
 Requires:       wgt-installer = %{version}
 BuildRequires:  boost-devel
 BuildRequires:  cmake
-BuildRequires:  gtest-devel
 BuildRequires:  app-installers-tests
 BuildRequires:  pkgconfig(app-installers)
 BuildRequires:  pkgconfig(manifest-parser)
@@ -24,6 +23,7 @@ BuildRequires:  pkgconfig(libwebappenc)
 BuildRequires:  pkgconfig(tpk-installer)
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(libgum)
+BuildRequires:  pkgconfig(gmock)
 
 %description
 This is a package that installs the WGT backend of pkgmgr.
@@ -58,7 +58,13 @@ cp %{SOURCE1001} .
 cp %{SOURCE1002} .
 
 %build
-%cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}
+%ifnarch x86_64 aarch64
+ISARC64=0
+%else
+ISARC64=1
+%endif
+%cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} \
+         -DISARC64=${ISARC64}
 make %{?_smp_mflags}
 
 %install
@@ -67,8 +73,10 @@ mkdir -p %{buildroot}/etc/package-manager/backend
 ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/wgt
 
 %post -n wgt-installer-tests
-/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-installer-ut/smoke-test
-/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-installer-ut/smoke-test-helper
+/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/smoke-test
+/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/smoke-test-helper
+/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/hybrid-smoke-test-helper
+/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner,cap_mac_override=eip %{_bindir}/wgt-installer-ut/extensive-smoke-test
 
 %files
 %manifest wgt-backend.manifest
@@ -94,7 +102,9 @@ ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/
 %files -n wgt-installer-tests
 %manifest wgt-installer-tests.manifest
 %{_bindir}/wgt-installer-ut/*
+%ifnarch x86_64 aarch64
 %{_datadir}/wgt-installer-ut/*
+%endif
 %{_libdir}/libwgt-smoke-utils.so*
 %{_includedir}/app-installers/smoke_tests/wgt_smoke_utils.h