Release version 0.12.12
[platform/core/appfw/wgt-backend.git] / packaging / wgt-backend.spec
index 9d9f89a..71b7e9d 100644 (file)
@@ -1,9 +1,6 @@
-#Available values for profile: mobile, wearable, tv, ivi, common
-%{!?profile:%define profile tv}
-
 Name:           wgt-backend
 Summary:        Application installer backend for WGT
-Version:        0.1
+Version:        0.12.12
 Release:        1
 Group:          Application Framework/Package Management
 License:        Apache-2.0
@@ -15,12 +12,16 @@ Source1001:     wgt-backend-tests.manifest
 BuildRequires:  boost-devel
 BuildRequires:  cmake
 BuildRequires:  gtest-devel
+BuildRequires:  app-installers-tests
 BuildRequires:  pkgconfig(app-installers)
 BuildRequires:  pkgconfig(manifest-parser)
 BuildRequires:  pkgconfig(wgt-manifest-handlers)
 BuildRequires:  pkgconfig(pkgmgr-installer)
+BuildRequires:  pkgconfig(pkgmgr-types)
 BuildRequires:  pkgconfig(libwebappenc)
 BuildRequires:  pkgconfig(tpk-installer)
+BuildRequires:  pkgconfig(vconf)
+BuildRequires:  pkgconfig(libgum)
 
 %description
 This is a package that installs the WGT backend of pkgmgr.
@@ -39,12 +40,7 @@ cp %{SOURCE1000} .
 cp %{SOURCE1001} .
 
 %build
-#Variable for setting symlink to runtime
-runtime_path=%{_bindir}/xwalk-launcher
-%if "%{profile}" == "mobile" || "%{profile}" == "wearable" || "%{profile}" == "tv"
-runtime_path=%{_bindir}/wrt
-%endif
-%cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} -DWRT_LAUNCHER=${runtime_path}
+%cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}
 make %{?_smp_mflags}
 
 %install
@@ -53,13 +49,16 @@ mkdir -p %{buildroot}/etc/package-manager/backend
 ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/wgt
 
 %post tests
-/usr/sbin/setcap cap_dac_override=eip %{_bindir}/wgt-backend-ut/smoke-test
+/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-backend-ut/smoke-test
+/usr/sbin/setcap cap_chown,cap_dac_override,cap_fowner=eip %{_bindir}/wgt-backend-ut/smoke-test-helper
 
 %files
 %manifest wgt-backend.manifest
 %license LICENSE
 %{_sysconfdir}/package-manager/backend/wgt
+%{_sysconfdir}/package-manager/backendlib/libwgt.so
 %{_bindir}/wgt-backend
+%{_datadir}/wgt-backend/default.png
 
 %files tests
 %manifest wgt-backend-tests.manifest