Release version 0.7.7
[platform/core/appfw/wgt-backend.git] / packaging / wgt-backend.spec
index dbc504c..4c8f351 100644 (file)
@@ -1,6 +1,6 @@
 Name:           wgt-backend
 Summary:        Application installer backend for WGT
-Version:        0.1
+Version:        0.7.7
 Release:        1
 Group:          Application Framework/Package Management
 License:        Apache-2.0
@@ -16,8 +16,11 @@ BuildRequires:  pkgconfig(app-installers)
 BuildRequires:  pkgconfig(manifest-parser)
 BuildRequires:  pkgconfig(wgt-manifest-handlers)
 BuildRequires:  pkgconfig(pkgmgr-installer)
+BuildRequires:  pkgconfig(pkgmgr-types)
 BuildRequires:  pkgconfig(libwebappenc)
 BuildRequires:  pkgconfig(tpk-installer)
+BuildRequires:  pkgconfig(vconf)
+BuildRequires:  pkgconfig(libgum)
 
 %description
 This is a package that installs the WGT backend of pkgmgr.
@@ -36,12 +39,7 @@ cp %{SOURCE1000} .
 cp %{SOURCE1001} .
 
 %build
-#Variable for setting symlink to runtime
-runtime_path=%{_bindir}/xwalk-launcher
-%if "%{profile}" == "mobile" || "%{profile}" == "wearable" || "%{profile}" == "tv"
-runtime_path=%{_bindir}/wrt
-%endif
-%cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type} -DWRT_LAUNCHER=${runtime_path}
+%cmake . -DCMAKE_BUILD_TYPE=%{?build_type:%build_type}
 make %{?_smp_mflags}
 
 %install
@@ -57,6 +55,7 @@ ln -s %{_bindir}/wgt-backend %{buildroot}%{_sysconfdir}/package-manager/backend/
 %manifest wgt-backend.manifest
 %license LICENSE
 %{_sysconfdir}/package-manager/backend/wgt
+%{_sysconfdir}/package-manager/backendlib/libwgt.so
 %{_bindir}/wgt-backend
 %{_datadir}/wgt-backend/default.png