fix weston launch error
[platform/upstream/weston.git] / packaging / weston.spec
index 9ce46d5..90d53d6 100644 (file)
@@ -35,7 +35,7 @@ BuildRequires:  pam-devel
 BuildRequires:  pkgconfig
 BuildRequires:  xz
 BuildRequires:  pkgconfig(cairo)
-BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
+#BuildRequires:  pkgconfig(cairo-egl) >= 1.11.3
 BuildRequires:  pkgconfig(egl) >= 7.10
 %if %{with rdp}
 BuildRequires:  pkgconfig(freerdp)
@@ -59,7 +59,7 @@ BuildRequires:  pkgconfig(mtdev) >= 1.1.0
 #BuildRequires:  pkgconfig(pangocairo)
 BuildRequires:  pkgconfig(wayland-protocols)
 BuildRequires:  pkgconfig(pixman-1)
-BuildRequires:  pkgconfig(poppler-glib)
+#BuildRequires:  pkgconfig(poppler-glib)
 BuildRequires:  pkgconfig(wayland-client)
 BuildRequires:  pkgconfig(wayland-egl)
 BuildRequires:  pkgconfig(wayland-server)
@@ -121,7 +121,6 @@ cp %{SOURCE1001} .
          --disable-xwayland-test \
          --disable-x11-compositor \
          --disable-rpi-compositor \
-         --with-cairo=glesv2 \
          %{?extra_config_options1:%extra_config_options1} \
          %{?extra_config_options2:%extra_config_options2} \
          %{?extra_config_options3:%extra_config_options3} \
@@ -140,8 +139,8 @@ install -m 755 weston-simple-shm %{buildroot}%{_bindir}
 install -m 755 weston-simple-egl %{buildroot}%{_bindir}
 install -m 755 weston-simple-damage %{buildroot}%{_bindir}
 install -m 755 weston-presentation-shm %{buildroot}%{_bindir}
-install -m 755 weston-nested-client %{buildroot}%{_bindir}
-install -m 755 weston-nested %{buildroot}%{_bindir}
+#install -m 755 weston-nested-client %{buildroot}%{_bindir}
+#install -m 755 weston-nested %{buildroot}%{_bindir}
 install -m 755 weston-multi-resource %{buildroot}%{_bindir}
 install -m 755 weston-flower %{buildroot}%{_bindir}
 install -m 755 weston-image %{buildroot}%{_bindir}
@@ -215,8 +214,8 @@ getent group weston-launch >/dev/null || %{_sbindir}/groupadd -r weston-launch
 %{_bindir}/weston-simple-egl
 %{_bindir}/weston-simple-damage
 %{_bindir}/weston-presentation-shm
-%{_bindir}/weston-nested-client
-%{_bindir}/weston-nested
+#%{_bindir}/weston-nested-client
+#%{_bindir}/weston-nested
 %{_bindir}/weston-multi-resource
 %{_bindir}/weston-flower
 %{_bindir}/weston-image