[Release] Webkit2-efl-123997_0.11.22
[framework/web/webkit-efl.git] / packaging / webkit2-efl.spec
index 8179bbd..746fbb6 100644 (file)
@@ -1,15 +1,16 @@
 Name: webkit2-efl
 Summary: Webkit2 EFL
-Version: 123997_0.9.84
+Version: 123997_0.11.22
 Release: 1
-Group: System/Libraries
-License: BSD
+Group: Applications/Internet
+License: LGPLv2.1 or BSD
 Source0: %{name}-%{version}.tar.gz
 
 Requires(post): /sbin/ldconfig
+Requires(post): xkeyboard-config
 Requires(postun): /sbin/ldconfig
 
-BuildRequires: cmake, edje-bin, embryo-bin, python, bison, flex, gperf, libjpeg-turbo-devel, perl, gettext
+BuildRequires: cmake, edje-bin, embryo-bin, python, bison, flex, gperf, libjpeg-turbo-devel, perl, gettext, ruby
 BuildRequires: pkgconfig(cairo)
 BuildRequires: pkgconfig(capi-network-connection)
 BuildRequires: pkgconfig(capi-telephony-network-info)
@@ -24,6 +25,7 @@ BuildRequires: pkgconfig(eina)
 BuildRequires: pkgconfig(elementary)
 BuildRequires: pkgconfig(enchant)
 BuildRequires: pkgconfig(evas)
+BuildRequires: pkgconfig(feedback)
 BuildRequires: pkgconfig(fontconfig)
 BuildRequires: pkgconfig(freetype2)
 BuildRequires: pkgconfig(glib-2.0)
@@ -53,7 +55,8 @@ BuildRequires: pkgconfig(ui-gadget-1)
 BuildRequires: pkgconfig(xext)
 BuildRequires: pkgconfig(libavcodec)
 BuildRequires: pkgconfig(gles20)
-
+BuildRequires: pkgconfig(tts)
+BuildRequires: pkgconfig(capi-system-power)
 
 
 %description
@@ -109,7 +112,7 @@ cd $WEBKIT_BUILD_DIR
 export MAKE_OPTION=%{MAKE_OPTION}
 if [ "{MAKE_OPTION}" == "${MAKE_OPTION#%}" ]
 then
-    cmake $SOURCE_DIR -DPORT=Efl -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DENABLE_WEBKIT=Off -DENABLE_WEBKIT2=On -DENABLE_ALLINONE=On -DEFL_TARGET=%{EFL_TARGET} $TIZEN_WEBKIT_EXTRA_OPTIONS
+    cmake $SOURCE_DIR -DPORT=Efl -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DENABLE_WEBKIT=Off -DENABLE_WEBKIT2=On -DENABLE_ALLINONE=On -DEFL_TARGET=%{EFL_TARGET} -DDefaultTheme_RESOURCE_NAME=webkit.edj $TIZEN_WEBKIT_EXTRA_OPTIONS
     make %{?jobs:-j%jobs}
 else
     make %{MAKE_OPTION} %{?jobs:-j%jobs}
@@ -127,30 +130,25 @@ fi
 cd $WEBKIT_BUILD_DIR
 %make_install
 mkdir -p %{buildroot}/usr/share/edje
-cp ./WebKit/efl/DefaultTheme/default.edj %{buildroot}/usr/share/edje/webkit.edj
 
 %post
 #!/bin/sh
 #change file permissions
 # 1. libraries
-chmod 644 /usr/lib/libewebkit2.so
+chmod 644 %{_libdir}/libewebkit2.so
 # 2. Resources
 chmod 644 /usr/share/edje/webkit.edj
-#################################################################
-# Set executin script
-#################################################################
-echo "[WebKit2-EFL] postinst done ..."
 
 %postun
 
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root,-)
-/usr/lib/*.so*
-/usr/bin/*
+%{_libdir}/*.so*
+%{_bindir}/*
 /usr/share/*
 
 %files devel
 %defattr(-,root,root,-)
-/usr/include/*
-/usr/lib/pkgconfig/*
+%{_includedir}/*
+%{_libdir}/pkgconfig/*