modify wrong changelog date
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
index 0c43b58..d23fc1f 100644 (file)
@@ -1,5 +1,5 @@
 Name:       web-ui-fw
-Version:    0.2.25
+Version:    0.2.29
 Release:    0
 Summary:    Tizen Web UI Framework Library
 Group:      Development/Other
@@ -7,17 +7,21 @@ License:    MIT
 BuildArch:  noarch
 BuildRequires:  make
 BuildRequires:  nodejs
-%ifarch %{arm}
-BuildRequires:  nodejs-x86-arm
-%endif
 
 Source0:    %{name}-%{version}.tar.gz
+Source1001:    %{name}.manifest
+Source1002:    web-ui-fw-theme-tizen-white.manifest
+Source1003:    web-ui-fw-theme-tizen-black.manifest
+Source1004:    web-ui-fw-theme-default.manifest
+Source1005:    web-ui-fw-devel.manifest
+Source1006:    web-ui-fw-demo-tizen-winsets.manifest
 
 %description
 Tizen Web UI Framework library and theme packages
 
 %prep
 %setup -q
+cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} %{SOURCE1006} .
 
 %build
 make all
@@ -28,7 +32,7 @@ make DESTDIR=%{buildroot} install
 %post
 
 %files
-%manifest web-ui-fw.manifest
+%manifest %{name}.manifest
 /usr/share/tizen-web-ui-fw/*/js/*.js
 /usr/share/tizen-web-ui-fw/*/js/cultures
 /usr/share/tizen-web-ui-fw/latest
@@ -80,6 +84,7 @@ Summary:    Tizen Web UI Framework Developer's files
 %Description -n web-ui-fw-devel
     Tizen Web UI Framework Developer's files
 %files -n web-ui-fw-devel
+%manifest web-ui-fw-devel.manifest
 /usr/share/tizen-web-ui-fw/bin
 /usr/share/tizen-web-ui-fw/template
 /usr/share/tizen-web-ui-fw/*/js/src
@@ -92,12 +97,65 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
 %Description -n web-ui-fw-demo-tizen-winsets
     Tizen Web UI Framework Demo Application: tizen winset demo
 %files  -n web-ui-fw-demo-tizen-winsets
+%manifest web-ui-fw-demo-tizen-winsets.manifest
 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
 
 
 ###############################
 %changelog
-* Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
+* Fri May 10 2013 Hyunjung Kim <hjnim.kim@samsung.com> 0.2.29
+       - loader: change a warn msg to debug msg
+       - Radio: Radio issue has been fixed ( N_SE-38015 )
+       - Add gallery3D source to the flora license list
+       - Slider: JQM patch fixed ( event.target match )
+       - Tizen-winset: remove unnecessary file
+
+* Tue May 07 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.28
+       - Orientation : add landscape UX
+       - ToggleSwitch : divide jQM and Tizen slider on dragging outside of toggle area
+       - Slider: Popup slider issue has been fixed ( N_SE-36430 )
+
+* Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
+       - Splitview: Fix popup error
+       - Tests: Add slider tests checking if jqm slider is used for select elements
+       - Adjust the latest GUI
+       - Handler: Adjust the latest GUI
+       - Swipe: Adjust the latest GUI
+       - Fastscroll: Adjust the latest GUI
+       - ToggleSwitch : bug fix
+       - TizenWinset : bug fix(N_SE-36666)
+       - Gallery3d: Fix Gallery3d TC failure
+       - UnitTC: fix virtualgrid test error
+       - Popup: popup background image have been added
+       - Tokentextarea: Use jQM popup instead of window.alert().
+       - Splitview: Use jQM popup instead of window.alert().
+       - Splitview: Change an option name to start with a capital letter
+       - License: Change flora license version
+       - Tabbar: Adjust the latest GUI
+       - Tokentextarea: Change from 'px' to 'em.'
+       - Fastscroll: Add 'orientationchange' event handler.
+       - Gallery3d: Fix null reference error
+
+* Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
+       - PageLayout : bug fix
+       - Gallery3d: Change timing of 'gl-matrix' library's execution
+       - Replace in LoadTheme function strings build with array join with the string concat
+       - Contextpopup: context popup reposition module has been added
+       - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
+       - Splitview: Fix the touchend event error.
+       - Gallery3d: Change event registration method from $.bind() to $.on()
+       - Scrollview : remove useless setTimeout in case scrolls go outside
+       - Naviframe : adjust new SIP down button
+       - Timepicker: Added return false; after vclick
+       - Popupwindow: reserved words has been removed
+       - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
+       - TizenWinset : set default margin for checkbox demo
+       - Tizenwinset: Context popup demo has been changed
+       - TizenDemo : add initial orientation mode to popup demo
+       - Widgets: removed parsing error for legacy javascript engine
+       - Delegate init of popup widget with delegateSelfInitWithSingleSelector
+
+* Thu Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
        - Pinch: pinch event re-implementation to use size
        - Pagelayout : prevent code inserting window.innerHeight when content calculate
        - BlachTheme : add missing icon (SIP down)
@@ -574,14 +632,14 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
        - dayselector: removed
        - expandablelist: removed
 
-* Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
+* Mon Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
 - FIX:
        - chang searchbar/slider images
        - delete redundant button images
 - Spec changes:
        - Change widget name: shortcutscroll -> fastscroll
 
-* Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
+* Fri Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
 - FIX:
        - jqm1.2: Change collapsible style to meet expandable list
        - remove jquery-geo-1.0.a4
@@ -762,7 +820,7 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
        - searchbar: don't hide icon
        - popup: update JQM poup widget
 
-* Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
+* Wed Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
 - FIX:
        - controlbar: set correct controlbar width of last element
        - slider: get popup enable value correctly
@@ -778,7 +836,7 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
 - Spec changes:
        - controlbar: update icons
 
-* Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
+* Wed Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
 - FIX:
        - notification: fix typo
 - Spec changes:
@@ -852,27 +910,27 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
        - default theme tizen-gray to tizen-white
        - set default page transition to none
 
-* Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
+* Thu Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
 - FIX :
        - Back Button : enlarge backbutton click size for white theme
 - Feature :
        - Expandable List : Add refresh api
-* Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
+* Thu Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
 - FIX :
        - click event touch threshold tuning
 
-* Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
-- FIX : 
+* Thu Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
+- FIX :
        - Add back button highlight effect for white theme
 
-* Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
-- FIX : 
+* Wed Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
+- FIX :
        - IME checkroutine update, improve relayout on resize event
-       - Add highlight effect for radio button list 
+       - Add highlight effect for radio button list
        - Scrollview : fix condition of updatelayout event
 - Feature : progressing : add show/hide api
 
-* Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
+* Fri Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
 - FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
        add default theme option on buttonMarkup for tizen theme
        [searchbar] first fix : focus/blur fixed