Fix manifests
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
index dad719a..b990fbe 100644 (file)
@@ -1,5 +1,5 @@
 Name:       web-ui-fw
-Version:    0.2.26
+Version:    0.2.29
 Release:    0
 Summary:    Tizen Web UI Framework Library
 Group:      Development/Other
@@ -12,12 +12,19 @@ BuildRequires:  nodejs-x86-arm
 %endif
 
 Source0:    %{name}-%{version}.tar.gz
+Source1001:    %{name}.manifest
+Source1002:    web-ui-fw-theme-tizen-white.manifest
+Source1003:    web-ui-fw-theme-tizen-black.manifest
+Source1004:    web-ui-fw-theme-default.manifest
+Source1005:    web-ui-fw-devel.manifest
+Source1006:    web-ui-fw-demo-tizen-winsets.manifest
 
 %description
 Tizen Web UI Framework library and theme packages
 
 %prep
 %setup -q
+cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} %{SOURCE1006} .
 
 %build
 make all
@@ -28,7 +35,7 @@ make DESTDIR=%{buildroot} install
 %post
 
 %files
-%manifest web-ui-fw.manifest
+%manifest %{name}.manifest
 /usr/share/tizen-web-ui-fw/*/js/*.js
 /usr/share/tizen-web-ui-fw/*/js/cultures
 /usr/share/tizen-web-ui-fw/latest
@@ -80,6 +87,7 @@ Summary:    Tizen Web UI Framework Developer's files
 %Description -n web-ui-fw-devel
     Tizen Web UI Framework Developer's files
 %files -n web-ui-fw-devel
+%manifest web-ui-fw-devel.manifest
 /usr/share/tizen-web-ui-fw/bin
 /usr/share/tizen-web-ui-fw/template
 /usr/share/tizen-web-ui-fw/*/js/src
@@ -92,11 +100,45 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
 %Description -n web-ui-fw-demo-tizen-winsets
     Tizen Web UI Framework Demo Application: tizen winset demo
 %files  -n web-ui-fw-demo-tizen-winsets
+%manifest web-ui-fw-demo-tizen-winsets.manifest
 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
 
 
 ###############################
 %changelog
+* Fri May 10 2013 Hyunjung Kim <hjnim.kim@samsung.com> 0.2.29
+       - loader: change a warn msg to debug msg
+       - Radio: Radio issue has been fixed ( N_SE-38015 )
+       - Add gallery3D source to the flora license list
+       - Slider: JQM patch fixed ( event.target match )
+       - Tizen-winset: remove unnecessary file
+
+* Tue May 07 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.28
+       - Orientation : add landscape UX
+       - ToggleSwitch : divide jQM and Tizen slider on dragging outside of toggle area
+       - Slider: Popup slider issue has been fixed ( N_SE-36430 )
+
+* Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
+       - Splitview: Fix popup error
+       - Tests: Add slider tests checking if jqm slider is used for select elements
+       - Adjust the latest GUI
+       - Handler: Adjust the latest GUI
+       - Swipe: Adjust the latest GUI
+       - Fastscroll: Adjust the latest GUI
+       - ToggleSwitch : bug fix
+       - TizenWinset : bug fix(N_SE-36666)
+       - Gallery3d: Fix Gallery3d TC failure
+       - UnitTC: fix virtualgrid test error
+       - Popup: popup background image have been added
+       - Tokentextarea: Use jQM popup instead of window.alert().
+       - Splitview: Use jQM popup instead of window.alert().
+       - Splitview: Change an option name to start with a capital letter
+       - License: Change flora license version
+       - Tabbar: Adjust the latest GUI
+       - Tokentextarea: Change from 'px' to 'em.'
+       - Fastscroll: Add 'orientationchange' event handler.
+       - Gallery3d: Fix null reference error
+
 * Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
        - PageLayout : bug fix
        - Gallery3d: Change timing of 'gl-matrix' library's execution
@@ -881,13 +923,13 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
        - click event touch threshold tuning
 
 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
-- FIX : 
+- FIX :
        - Add back button highlight effect for white theme
 
 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
-- FIX : 
+- FIX :
        - IME checkroutine update, improve relayout on resize event
-       - Add highlight effect for radio button list 
+       - Add highlight effect for radio button list
        - Scrollview : fix condition of updatelayout event
 - Feature : progressing : add show/hide api