Fix manifests
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
index 7e1a8ff..b990fbe 100644 (file)
@@ -1,5 +1,5 @@
 Name:       web-ui-fw
-Version:    0.2.20
+Version:    0.2.29
 Release:    0
 Summary:    Tizen Web UI Framework Library
 Group:      Development/Other
@@ -12,12 +12,19 @@ BuildRequires:  nodejs-x86-arm
 %endif
 
 Source0:    %{name}-%{version}.tar.gz
+Source1001:    %{name}.manifest
+Source1002:    web-ui-fw-theme-tizen-white.manifest
+Source1003:    web-ui-fw-theme-tizen-black.manifest
+Source1004:    web-ui-fw-theme-default.manifest
+Source1005:    web-ui-fw-devel.manifest
+Source1006:    web-ui-fw-demo-tizen-winsets.manifest
 
 %description
 Tizen Web UI Framework library and theme packages
 
 %prep
 %setup -q
+cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} %{SOURCE1005} %{SOURCE1006} .
 
 %build
 make all
@@ -28,8 +35,9 @@ make DESTDIR=%{buildroot} install
 %post
 
 %files
-%manifest web-ui-fw.manifest
-/usr/share/tizen-web-ui-fw/*/js
+%manifest %{name}.manifest
+/usr/share/tizen-web-ui-fw/*/js/*.js
+/usr/share/tizen-web-ui-fw/*/js/cultures
 /usr/share/tizen-web-ui-fw/latest
 /usr/share/tizen-web-ui-fw/VERSION
 
@@ -39,6 +47,7 @@ BuildArch:  noarch
 Summary:    Tizen Web UI Framework Theme : tizen-gray
 %Description -n web-ui-fw-theme-tizen-gray
     Tizen Web UI Framework Theme : tizen-gray
+    Deprecated package, but some binaries still refer this.
 
 ###############################
 %package -n web-ui-fw-theme-tizen-white
@@ -52,6 +61,16 @@ Summary:    Tizen Web UI Framework Theme : tizen-white
 /usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
 
 ###############################
+%package -n web-ui-fw-theme-tizen-black
+BuildArch:  noarch
+Summary:    Tizen Web UI Framework Theme : tizen-black
+%Description -n web-ui-fw-theme-tizen-black
+    Tizen Web UI Framework Theme : tizen-black
+%files -n web-ui-fw-theme-tizen-black
+%manifest web-ui-fw-theme-tizen-black.manifest
+/usr/share/tizen-web-ui-fw/*/themes/tizen-black
+
+###############################
 %package -n web-ui-fw-theme-default
 BuildArch:  noarch
 Summary:    Tizen Web UI Framework Theme : default
@@ -68,8 +87,11 @@ Summary:    Tizen Web UI Framework Developer's files
 %Description -n web-ui-fw-devel
     Tizen Web UI Framework Developer's files
 %files -n web-ui-fw-devel
+%manifest web-ui-fw-devel.manifest
 /usr/share/tizen-web-ui-fw/bin
 /usr/share/tizen-web-ui-fw/template
+/usr/share/tizen-web-ui-fw/*/js/src
+/usr/share/tizen-web-ui-fw/*/js/depData.json
 
 ###############################
 %package -n web-ui-fw-demo-tizen-winsets
@@ -78,26 +100,161 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
 %Description -n web-ui-fw-demo-tizen-winsets
     Tizen Web UI Framework Demo Application: tizen winset demo
 %files  -n web-ui-fw-demo-tizen-winsets
+%manifest web-ui-fw-demo-tizen-winsets.manifest
 /usr/share/tizen-web-ui-fw/demos/tizen-winsets
 
 
 ###############################
 %changelog
-
-* Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
-       - JQM Navigation : remove page min-height
-       - Pagelayout : add refresh to pagelayout
-       - Tokentextarea: Changes 'remove' tests to asyncTest
-       - Popup: input tag alignment has been fixed
-       - Tokentextarea: add/remove events are deprecated.
-       - Contextpopup: Support horizontal list
-       - Select: icon z-index has been deleted
-       - Tizenwinset: ui widget order has been changed
-       - Tool: make web app template disable context menu by default
-       - Tizen-winset: change tips for using listview
-       - Loader: calculate font size with mobile width
-       - Naviframe : fix header's back button position
-       - TizenWinset : move locale info to another file
+* Fri May 10 2013 Hyunjung Kim <hjnim.kim@samsung.com> 0.2.29
+       - loader: change a warn msg to debug msg
+       - Radio: Radio issue has been fixed ( N_SE-38015 )
+       - Add gallery3D source to the flora license list
+       - Slider: JQM patch fixed ( event.target match )
+       - Tizen-winset: remove unnecessary file
+
+* Tue May 07 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.28
+       - Orientation : add landscape UX
+       - ToggleSwitch : divide jQM and Tizen slider on dragging outside of toggle area
+       - Slider: Popup slider issue has been fixed ( N_SE-36430 )
+
+* Fri May 03 2013 Hyunjung kim <hjnim.kim@samsung.com> 0.2.27
+       - Splitview: Fix popup error
+       - Tests: Add slider tests checking if jqm slider is used for select elements
+       - Adjust the latest GUI
+       - Handler: Adjust the latest GUI
+       - Swipe: Adjust the latest GUI
+       - Fastscroll: Adjust the latest GUI
+       - ToggleSwitch : bug fix
+       - TizenWinset : bug fix(N_SE-36666)
+       - Gallery3d: Fix Gallery3d TC failure
+       - UnitTC: fix virtualgrid test error
+       - Popup: popup background image have been added
+       - Tokentextarea: Use jQM popup instead of window.alert().
+       - Splitview: Use jQM popup instead of window.alert().
+       - Splitview: Change an option name to start with a capital letter
+       - License: Change flora license version
+       - Tabbar: Adjust the latest GUI
+       - Tokentextarea: Change from 'px' to 'em.'
+       - Fastscroll: Add 'orientationchange' event handler.
+       - Gallery3d: Fix null reference error
+
+* Fri Apr 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.26
+       - PageLayout : bug fix
+       - Gallery3d: Change timing of 'gl-matrix' library's execution
+       - Replace in LoadTheme function strings build with array join with the string concat
+       - Contextpopup: context popup reposition module has been added
+       - Pagelayout : skip to calculate min-height using data-scroll="none"(Issue: DCM-1453)
+       - Splitview: Fix the touchend event error.
+       - Gallery3d: Change event registration method from $.bind() to $.on()
+       - Scrollview : remove useless setTimeout in case scrolls go outside
+       - Naviframe : adjust new SIP down button
+       - Timepicker: Added return false; after vclick
+       - Popupwindow: reserved words has been removed
+       - minor changes: replace one occurrence of array.join with string concat and simplify jQuery arguments
+       - TizenWinset : set default margin for checkbox demo
+       - Tizenwinset: Context popup demo has been changed
+       - TizenDemo : add initial orientation mode to popup demo
+       - Widgets: removed parsing error for legacy javascript engine
+       - Delegate init of popup widget with delegateSelfInitWithSingleSelector
+
+* Tue Apr 18 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.25
+       - Pinch: pinch event re-implementation to use size
+       - Pagelayout : prevent code inserting window.innerHeight when content calculate
+       - BlachTheme : add missing icon (SIP down)
+       - Scrollview : support absolute position
+       - tizen-winsets: change the font-family in virtualgrid demo to default
+       - TizenWinset : Change default font
+       - tizen-winsets: Change image link
+       - tizenwinset: change images for virtual grid pages
+
+* Tue Apr 16 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.24
+       - SegmentControl: 2-buttons display issue (N_SE-34200)
+       - Naviframe : remove unnecessary img positioning(N_SE-33969)
+       - Gallery: jslint error fix
+       - TizenWinset : remove landscape SIP on mode
+       - Tizen Black Theme png file changed
+       - Gallery: Images showing bug has been fixed
+       - Scrollview : change horizontal scrollview demo(N_SE-33997)
+       - Tizenwinset: added return false in popup sample
+       - Naviframe : support data-role="button" in header
+       - Additional UnitTC: tizen winset unit tc bugs have been fixed
+       - Checkbox : remove favorite button's display:block(N_SE-33896)
+       - UnitTC: QUnit path has been changed. Priority, function type check function has been added
+       - Tizen-winset : Footer changed from lower case to upper case.
+       - Slider: enhance performance fix
+       - UnitTC: Addtional unit tc ref path has been fixed
+       - virtualgrid: apply overscrolling images to the style of widget
+       - Tabbar : Change overscroll image(left/right)
+       - ensurens: optimizations
+       - ensurens: qunit tests
+       - Tokentextarea: Fix block size error
+       - Fastscroll: Add a feature to fade out Fastscroll widget.
+       - Fastscroll: Add a user interaction at the omitted items.
+       - ImageLoader: Performance fix: apply lazy loading for canvas element
+       - Tests: Add tests for $.imageloader
+       - SegmentControl: 2-buttons display issue (N_SE-34200)
+       - virtuallist: fix width resizing trigger
+       - Timepicker: timepicker is closed when orientationchange event fired
+       - TizenWinset : Tabbar-persist issue.(N_SE-33996)
+       - Add Flora license
+       - collapsible: Fix collapsible list animation bug
+
+* Wed Apr 10 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.23
+       - Naviframe : modify SIP down button's position
+       - Core: Performance fix for disableSelection and enableSelection
+       - Tests: Core tests for disableSelection
+       - patch: fix small mistakes on the patches
+       - virtuallist: Change demo button style
+       - Button: btn-icon only css has been changed
+       - loader: Fix screen-width option processing
+       - pagelayout: Remember back key when it is hidden
+       - Tizen Black Theme : Tizen black theme png file changed.
+       - UnitTC: tizen winset unit tc bugs have been fixed
+       - TizenWinset: Swipe list sample has been fixed
+       - Radio : remove default radio's width(N_SE-33579)
+       - Scrollview : divide x/y overflow attribute
+       - Gallery: orientation image showing issue has been fixed
+       - Gallery: remove method bug has been fixed
+       - virtualgrid : fix unit-test error and increase test items
+       - Gallery3d: Modify demo & source codes for visibility enhancement.
+       - Gallery3d: Reduce loading time of widget
+       - Gallery3d: Change files' format to unix
+       - Contextpopup: context popup close when window resize event fire
+       - Popup: reverse orientation bug has been fixed
+       - Tokentextarea: modify description
+       - Multimediaview: modify description
+       - JQM: Do not add ui-btn-icon-only class at the select button
+       - build: tizen-black theme package
+       - Tizenwinset: popup script has been removed
+       - Tizenwinset: substring split view text message
+       - Timepicker: data-changed event will be deprecated
+
+* Fri Apr 5 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.22
+       - tizen-winsets: Fix demo menu
+       - Tizenwinset: Reorder tizenwinset menu
+       - SearchBar: Header button size issue has been fixed
+       - Swipe: list item overflow: hidden has been added
+       - Tizenwinset: href has been added in grouped list
+       - Tizenwinset: Page transition page has been added
+       - Tizenwinset: Radio description has been fixed
+       - This patch fixes problem when base url is changed when site is prefetched.
+       - Entry : limit textarea's width (N_SE-28653)
+       - Naviframe : hide backbutton in case SIP up(remove backbutton makes problem in binding event)
+       - Gallery : next, prev images position bug has been fixed
+       - Multimediaview: Fix display error while handling orientationchange event.
+       - Pagelayout : modify innerHeight dpr calculation in non scrollview mode
+       - Datetimepicker: picker position has been fixed when browser resize event fired
+       - Tips: generate elements sample page javascript has been fixed
+       - Tokentextarea: Fix Tizen-winsets demo.
+
+* Wed Apr 3 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.21
+       - VirtualGrid: Fix errors on centerTo and resize methods
+       - loader: Fix default font size at device-width viewport
+       - scrollview : remove overflow-x property
+       - Naviframe : fix backbutton position/ change down button icon
+       - Naviframe : bug fix
+       - Tizenwinset : Tizen-winset demo page titles changed Tizen-winset demo page titles changed from lower case to upper case.
 
 * Fri Mar 29 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.20
        - JQM Navigation : remove page min-height
@@ -766,13 +923,13 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
        - click event touch threshold tuning
 
 * Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
-- FIX : 
+- FIX :
        - Add back button highlight effect for white theme
 
 * Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
-- FIX : 
+- FIX :
        - IME checkroutine update, improve relayout on resize event
-       - Add highlight effect for radio button list 
+       - Add highlight effect for radio button list
        - Scrollview : fix condition of updatelayout event
 - Feature : progressing : add show/hide api