0.2.7 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
index ebd262d..b31989c 100644 (file)
@@ -1,5 +1,5 @@
 Name:       web-ui-fw
-Version:    0.1.44
+Version:    0.2.7
 Release:    0
 Summary:    Tizen Web UI Framework Library
 Group:      Development/Other
@@ -28,8 +28,10 @@ make DESTDIR=%{buildroot} install
 %post
 
 %files
+%manifest web-ui-fw.manifest
 /usr/share/tizen-web-ui-fw/*/js
 /usr/share/tizen-web-ui-fw/latest
+/usr/share/tizen-web-ui-fw/VERSION
 
 ###############################
 %package -n web-ui-fw-theme-tizen-gray
@@ -39,22 +41,15 @@ Summary:    Tizen Web UI Framework Theme : tizen-gray
     Tizen Web UI Framework Theme : tizen-gray
 
 ###############################
-%package -n web-ui-fw-theme-tizen-black
-BuildArch:  noarch
-Summary:    Tizen Web UI Framework Theme : tizen-black
-%Description -n web-ui-fw-theme-tizen-black
-    Tizen Web UI Framework Theme : tizen-black
-%files -n web-ui-fw-theme-tizen-black
-/usr/share/tizen-web-ui-fw/*/themes/tizen-black
-
-###############################
 %package -n web-ui-fw-theme-tizen-white
 BuildArch:  noarch
 Summary:    Tizen Web UI Framework Theme : tizen-white
 %Description -n web-ui-fw-theme-tizen-white
     Tizen Web UI Framework Theme : tizen-white
 %files -n web-ui-fw-theme-tizen-white
+%manifest web-ui-fw-theme-tizen-white.manifest
 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
+/usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
 
 ###############################
 %package -n web-ui-fw-theme-default
@@ -63,6 +58,7 @@ Summary:    Tizen Web UI Framework Theme : default
 %Description -n web-ui-fw-theme-default
     Tizen Web UI Framework Theme : default
 %files -n web-ui-fw-theme-default
+%manifest web-ui-fw-theme-default.manifest
 /usr/share/tizen-web-ui-fw/*/themes/default
 
 ###############################
@@ -88,6 +84,310 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
 ###############################
 %changelog
 
+* Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
+       - slider: set text container's width as text length
+       - Timepicker: li max-width has been changed
+       - remove experimental feature - mapview.
+       - scrollview: added conditions for finding slider
+       - UnitTC: Pass,error count save method has been changed
+       - confix.xml: default config added for tizen basic applications
+       - Swipe: p tag margin value is set '0'
+       - packaging: remove unused file
+       - tabbar : bug fix
+       - list demo : bug fix
+       - tizen-winsets: gallery: move to new section
+       - tizen-winsets: autodivider: removes link of list
+       - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
+       - pagelayout : padding calculate change, ime footer check changed
+       - tizen-winsets: searchbar: scroll to the top when type the character
+       - searchbar : bug fix
+       - demo: Fix virtuallist demo following new list style
+       - demo: Add word-wrap:break-word and remove parag. width
+       - Demo: button max-width has been set( 3 buttons in popup )
+       - back button control demo : bug fix
+       - toggleswitch : demo page modify
+       - slider: add margin-top and margin-bottom
+       - tabbar demo : bug fix
+       - Popup: IME hide when popup is closed
+       - token textarea : bug fix
+       - Timepicker: change get attribute method
+       - footer demo : bug fix
+       - unit-test: gallery: add new APIs
+       - gallery: adds support new APIs
+
+* Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
+       - JQM: patches cleanup
+       - Button: data-corners attribute has been added
+       - unit-test: slider: fix class name of background
+       - progressbar, slider: fix less variable typo
+       - Tabbar : VI update
+       - notification: add top position at fix class
+       - demo: entry demo page change
+       - css: .ui-disabled added
+       - tizen-winset: token textarea: remove back button at demo page
+       - theme: Remove unused less file
+       - pagelayout : content min height bug fix
+       - scrollview: skip the dragging when target is slider's handle
+       - scrollview: update and refactoring the scroll effect
+       - UnitTest:JQM Unit TC helper has been added,TCs have been modified
+       - Swipe: demo page html error has been fixed
+       - listview: Add add/delete animation (VI)
+       - Popup: demo page has been modified
+       - tizen demo : bug fix
+       - searchbar : demo page change(change front button and add behaviour)
+       - pagelayout : add min height to content
+       - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
+       - back button control demo : change url link to data-rel="back"
+       - loader: Skip loading theme CSS with a custom css code
+       - Button: support no-text in button
+       - collapsible: Fix syntax error
+       - slider: use data-highlight attribute
+       - collapsible: Rotate animation to collapsible heading icon
+       - toggleswitch : text switch bug fix
+       - remove candidates-calendarpicker
+       - Patch: Fix misc mistakes in JQM patches
+       - searchbar : animation change
+       - gallery: get the width correctly
+       - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
+       - collapsible: Add collapse/expand animation (VI)
+       - datetimepicker: VI update
+       - JQM: set transition to pop as default
+       - tabbar : bug fix in case none li element case
+       - scrollview: fix the drag bug
+       - Button: Button icon scrolltop, left has beed added
+       - Swipe: VI update and swipe speed has been changed
+       - jqm: fix errors in patch files
+       - unit-test: swipe: fixed the destroy test
+
+* Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
+       - Revert "[checkboxradio] exception handling for input"
+               This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
+               Tizen style supports no-label radio and checkbox when making lists.
+               So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
+
+* Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
+- Fix:
+       - modify segment background
+       - rearrange check, radio input
+       - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
+       - button: style has beed added(box,circle,nobg,round)
+       - favorite resource added
+       - demo/tizen-winsets: add footer and back button
+       - remove autodividers unit test
+       - add divider for tabbar
+       - checkboxradio: exception handling for input
+       - segment control backward compatiblity
+       - Fix collapsible unit-test
+       - remove toggleswitch
+       - add patch for remove segment text
+- Spec changes:
+       - replace controlbar to tabbar
+
+* Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
+- FIX:
+       - slider: add image
+       - button: data-icon support, styles fix
+       - progressbar: modify the background
+       - scrollview: auto scrolling bug fix
+       - pagelayout: IME concept is changed
+- Spec changes:
+       - dialogue: add edit mode
+       - nocontents: removed
+       - pagecontrol: removed
+       - dayselector: removed
+       - expandablelist: removed
+
+* Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
+- FIX:
+       - chang searchbar/slider images
+       - delete redundant button images
+- Spec changes:
+       - Change widget name: shortcutscroll -> fastscroll
+
+* Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
+- FIX:
+       - jqm1.2: Change collapsible style to meet expandable list
+       - remove jquery-geo-1.0.a4
+       - unit-test: rename from imageslider to gallery
+       - nocontent: add warning message
+       - Handler: Fix issues in jqm1.2
+       - Multimediaview: modify APIs & comments
+       - Mapview: Fix issues in jqm1.2
+       - JQM: clean up patches
+       - Swipelist: refactoring swipelist
+       - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
+       - rearrange button's data-icon resources
+- Spec changes:
+       - Virtualgrid: remove option ('data-itemcount')
+       - gallery: rename the widget from imageslider to gallery
+       - add new style for searchbar
+       [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
+
+* Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
+- FIX:
+       - fix jslint error
+       - remove unused files
+       - change naviframe style
+- Spec changes:
+       - applied jQuery Mobile 1.2.0
+       - remove optionheader
+
+* Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
+- FIX:
+       - fix unit tests
+       - remove unused theme files
+       - timepicker: text position fix
+       - scrollview: set dragstop when mouse is out of window
+       - listview: fix margin
+- Spec changes:
+       - support data-framework-viewport-width
+
+* Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
+- FIX:
+       - dayselector: fix size
+       - remove unised styles
+       - divider: set non-press effect to default option
+       - popupwindow: fix window closing failure
+       - handler: GUI implementation
+       - TC: fix unit TCs
+       - scrollview: fix padding size
+- Spec changes:
+       - Remove color widgets
+       - add $.tizen.pkgVersion for SDK
+- Etc.
+       - JSDuck documents
+
+* Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
+- FIX:
+       - Many winsets: Fix layout
+       - Footer: fix position to bottom
+- Spec changes:
+       - Remove color widgets
+
+* Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
+- FIX:
+       - Many widgets: New UX 0.6 theme implementation
+       - widgetex: init speed up
+       - scrollview: fix scrollbar and scale animation
+       - scrollview: fix scroll position when updatelayout is triggered
+       - header/footer: make textselection disable, except input type="text"
+
+* Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
+- FIX:
+       - Remove tizen-black theme package description
+
+* Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
+- FIX:
+       - Fix theme name to meet the change of system theme name: white->tizen
+       - Popupwindow: fix left position
+       - Remove black theme
+       - footer: remove label, legend drawing
+- Spec changes:
+       - UX guide v0.4 : button, layout
+
+* Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
+- FIX:
+       - expandablelist: icon color fix
+       - scrollview: Fix xy scroll
+       - footer: Remove dummy div
+       - Make string concatnation effective in inline-protos.sh
+- Spec changes:
+       - refresh header/footer when drag&drop event is fired in GUI builder
+       - searchbar: delete cancel button
+       - don't trigger updatelayout event when keyup event comes
+
+* Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
+- FIX:
+       - Toggleswitch: Change event name from 'changed' to 'change'
+       - Notification: Revert interval feature
+
+* Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
+- FIX:
+       - Fix SMACK manifest bug (S1-9098)
+
+* Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
+- FIX:
+       - handler: don't append a handler if handler is not enabled
+       - scrollview: use static value
+       - datetimepicker: fix date-format HH display error
+- ETC:
+       - provide jquery.min.js
+       - barlayout: codes clean
+       - remove unused file
+
+* Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
+- FIX:
+       - listview: change focused color
+       - multibuttonentry: code refactoring
+       - datetimepicker: modify date format when triggered date-changed event
+       - slider: fix the top of slider bar
+       - add event blocker when load a first page
+
+* Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
+- ETC.
+       - Move SMACK manifest files to the top SRCDIR
+
+* Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
+- FIX:
+       - Popup: Do not focus container
+       - Header: show backbutton when both tabbar and header are present together
+       - Multi button entry: text ellipsis, code refactoring
+
+* Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
+- ETC.
+       - Apply SMACK manifest
+
+* Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
+- FIX:
+       - JSLINT code clean-up
+       - scrollview: firefox support
+       - scrollview: fix finding slider handle
+       - list: tweak text ellipsis
+       - checkbox: fix selecting wrong label tag (N_SE-8370)
+       - imageslider: check parameter
+       - smallpopup: fix position
+       - searchbar: fix 'clear' button size
+- Spec changes:
+       - scrollview: support outer scroll
+       - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
+       - remove S/W IME control
+
+* Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
+- FIX:
+       - Add missing icon: controlbar
+       - scrollview: tune scrolling animatio ninterval
+       - datetimepicker: digit/triangle position
+       - datetimepicker: fix day overflow issue
+- Spec changes:
+       - scrollview: show scrollbar when page is showed
+       - scrollview: disable outer scroll
+       - extendablelist: change api with legacy support
+       - add ui-text-ellipsis class
+
+* Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
+- FIX:
+       - scrollveiw: fix height of view
+       - searchbar: support placeholder
+- Spec changes:
+       - add ui-text-ellipsis class
+
+* Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
+- FIX:
+       - scrollview: scrolling bug fix
+       - controlbar: fix width of controlbar item
+- Spec changes:
+       - searchbar: don't hide icon
+       - popup: update JQM poup widget
+
+* Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
+- FIX:
+       - controlbar: set correct controlbar width of last element
+       - slider: get popup enable value correctly
+       - use Date.now() instead of (new Data()).getTime()
+       - popupwindow: fix the background color of popup scroller
+       - listview: add padding-left to expandable list
+       - add ellipsis for title area support
+
 * Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
 - FIX:
        - swipelist: show list items correctly