fix arm build issue
[framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
index aad0036..4babcea 100644 (file)
@@ -1,14 +1,15 @@
 Name:       web-ui-fw
-Version:    0.1.42
+Version:    0.1.47
 Release:    0
 Summary:    Tizen Web UI Framework Library
 Group:      Development/Other
 License:    MIT
 BuildArch:  noarch
 BuildRequires:  make
-BuildRequires:  nodejs
 %ifarch %{arm}
 BuildRequires:  nodejs-x86-arm
+%else
+BuildRequires:  nodejs
 %endif
 
 Source0:    %{name}-%{version}.tar.gz
@@ -88,6 +89,43 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
 ###############################
 %changelog
 
+* Mon Sep 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.47
+- FIX:
+       - scrollveiw: fix height of view
+       - searchbar: support placeholder
+- Spec changes:
+       - add ui-text-ellipsis class
+
+* Fri Sep 07 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.46
+- FIX:
+       - scrollview: scrolling bug fix
+       - controlbar: fix width of controlbar item
+- Spec changes:
+       - searchbar: don't hide icon
+       - popup: update JQM poup widget
+
+* Fri Sep 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.45
+- FIX:
+       - controlbar: set correct controlbar width of last element
+       - slider: get popup enable value correctly
+       - use Date.now() instead of (new Data()).getTime()
+       - popupwindow: fix the background color of popup scroller
+       - listview: add padding-left to expandable list
+       - add ellipsis for title area support
+
+* Fri Aug 31 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.44
+- FIX:
+       - swipelist: show list items correctly
+       - datetimepicker: set last day, if day is overflowed
+- Spec changes:
+       - controlbar: update icons
+
+* Tue Aug 29 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.43
+- FIX:
+       - notification: fix typo
+- Spec changes:
+       - controlbar: update icons
+
 * Tue Aug 28 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.42
 - FIX:
        - multimediaview: video progress bar display normally for too samll