0.2.18 release
[platform/framework/web/web-ui-fw.git] / packaging / web-ui-fw.spec
index 07f0d95..171d3cd 100644 (file)
@@ -1,5 +1,5 @@
 Name:       web-ui-fw
-Version:    0.1.48
+Version:    0.2.18
 Release:    0
 Summary:    Tizen Web UI Framework Library
 Group:      Development/Other
@@ -28,8 +28,10 @@ make DESTDIR=%{buildroot} install
 %post
 
 %files
+%manifest web-ui-fw.manifest
 /usr/share/tizen-web-ui-fw/*/js
 /usr/share/tizen-web-ui-fw/latest
+/usr/share/tizen-web-ui-fw/VERSION
 
 ###############################
 %package -n web-ui-fw-theme-tizen-gray
@@ -39,22 +41,15 @@ Summary:    Tizen Web UI Framework Theme : tizen-gray
     Tizen Web UI Framework Theme : tizen-gray
 
 ###############################
-%package -n web-ui-fw-theme-tizen-black
-BuildArch:  noarch
-Summary:    Tizen Web UI Framework Theme : tizen-black
-%Description -n web-ui-fw-theme-tizen-black
-    Tizen Web UI Framework Theme : tizen-black
-%files -n web-ui-fw-theme-tizen-black
-/usr/share/tizen-web-ui-fw/*/themes/tizen-black
-
-###############################
 %package -n web-ui-fw-theme-tizen-white
 BuildArch:  noarch
 Summary:    Tizen Web UI Framework Theme : tizen-white
 %Description -n web-ui-fw-theme-tizen-white
     Tizen Web UI Framework Theme : tizen-white
 %files -n web-ui-fw-theme-tizen-white
+%manifest web-ui-fw-theme-tizen-white.manifest
 /usr/share/tizen-web-ui-fw/*/themes/tizen-white
+/usr/share/tizen-web-ui-fw/*/themes/tizen-tizen
 
 ###############################
 %package -n web-ui-fw-theme-default
@@ -63,6 +58,7 @@ Summary:    Tizen Web UI Framework Theme : default
 %Description -n web-ui-fw-theme-default
     Tizen Web UI Framework Theme : default
 %files -n web-ui-fw-theme-default
+%manifest web-ui-fw-theme-default.manifest
 /usr/share/tizen-web-ui-fw/*/themes/default
 
 ###############################
@@ -88,6 +84,486 @@ Summary:    Tizen Web UI Framework Demo Application: tizen winset demo
 ###############################
 %changelog
 
+* Thu Mar 7 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.18
+       - build: Fix Makefile to add globalize to the minified lib
+       - build-tools : upgrade less to v1.3.3
+       - demos : change normal js path to minified js
+       - Theme : remove reduantant less - dayselector, optionheader, nocontents
+       - multimediaview : fix full-screen mode.
+       - multimediaview : fix 'width', 'height' and 'fullScreen' methods
+       - Extendablelist: Added min-height "load more button" in listitem
+       - virtualgrid: adjusts VI effect for an overflow action
+       - ControlGroup : change ellipsis font color (press/normal)
+       - multimediaview: Add an error message to Multimediaview
+       - virtualgrid: adjusts triple flick gesture
+       - scrollview: add function for getting width of view
+       - scrollview: adds support x axis gesture scroll
+       - multimediaview : fix audio control
+       - tabbar : tabbar slide animation change
+       - TizenWinsetDemo : 2line-text demo bug fix
+       - collapsible: Fix demo to show radio button correctly in the collapsible list
+       - collapsible: Set listitem position to relative
+       - UnitTC: added list divider unit test
+       - Style: unnecessary color codes have been deleted and modified
+       - build: Module build implementation
+       - UnitTC: Additional unit testcases have been added
+       - listview : bug fix
+       - Naviframe : remove back button's hover effect
+       - TizenDemo : remove back button
+       - Transition: added more-button vi
+       - pinch: added new event called pinch
+       - Popup: css word-wrap:break-word has been added
+       - virtualgrid: memory leak fix
+       - progress: set to init state at pending bar
+       - progress: add margin of top/bottom
+       - unit-test: split progress test and progressbar test
+       - Tizen-winset: Context popup sample page guide text has been changed
+       - multimediaview: fix the height of widget when full-screen mode
+       - JQM: performance tuning
+
+* Tue Feb 19 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.17
+       - DialogueList : delete border top value / add sample's text ellipsis
+       - Tokentextarea: Add scroll-to-top for Grouping On/Off regarding #N_SE-24877
+       - Multimediaview: Fix mute function
+       - Tizen-winset: list vi index guide textbox has been removed
+       - Tizen-winset: custom button texts have been changed
+       - slider: move popup div to out of content
+       - TizenWinset: disable context popup in multimediaview
+       - Swipe: wrong style name has been fixed
+       - demo: add the sample at dialogue list
+       - listview: Add ui-li-has-right-btn class with toggleswitch
+       - WinsetDemo : change wrong title name
+
+* Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.16
+       - demo: checkbox: reduce button's width
+       - tabbar : delete right/left tab animation color
+       - scrollview: fix the scroll position at keydown event
+       - groupControl : change footer groupControl from min-width to percentage
+       - scrollview: get height of softkeyboard correctly
+       - tizen-winset: Add name attr to all radio inputs
+       - virtualgrid: changes event binding target
+       - scrollview: skip the drag if target is textarea
+       - scrollview: skip the dragging of parent scrollview
+       - scrollview: apply the scaling ratio to the soft keyboard
+       - demos: apply disabled option in textarea
+       - demo: remove unused codes
+       - demo: datetimepicker: show selected date correctly
+       - listview: Adjust bubble listitem width and margin
+       - pagelayout : change external refresh call and ime status follow only current page
+       - toggleSwitch : bug fix
+       - unit-test: slider: fix the move test
+       - handler: fix jslint error
+       - ToggleSwitch : set image toggleswitch background attribute
+
+* Mon Jan 28 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.15
+       - slider: increase the text width(N_SE-23397)
+       - virtualgrid: DOM element leak fix
+       - header: Move button top higher in header with tabbar(N_SE-22253)
+       - datatimepicker: don't open the popup before popupafterclose event is fired(N_SE-23027)
+       - handler: bug fix (regarding enableHandler function )
+       - demo:fix syntax error
+
+* Sat Jan 26 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.14
+       - demo: fix demo using tizen device API
+       - multimediaview: reset the height of container
+       - input: modify css correctly
+       - multimediaview: fix the height of widget
+       - gallery: bind create event
+       - progress: bind create event
+       - slider: bind create event
+       - progressbar: bind create event
+       - progressbar: event trigger correctly
+       - popup: fix height of popup scroller
+       - build: add continue option to jslint
+       - ctxpopup demo : bug fix
+       - demo: fix searchbar demo to use different IDs
+       - demo: extract routine executing Tizen device API
+       - toggleswitch : set default margin, delete box padding
+
+* Thu Jan 24 2013 Youmin Ha <youmin.ha@samsung.com> 0.2.13
+       - virtuallist: Prevent replacing contents on nonexist element
+       - JQM: Trim text in listitem to get index in autodivider
+       - JQM: Remove trailing whitespace in jqm patch
+       - scrollview: get the height including margin
+       - multimediaview: bug fix ( scrolling in full-screen mode )
+       - virtuallist: set listitem width to exclude listitem left/right margin
+       - demo: fix virtuallist sample layout
+       - progress: set the position explicitly
+       - progress: rename from progressing to progress
+       - build: remove unused files
+       - searchbar: fix jslint errors
+       - src: fix file permissions
+       - button : change jump left icon
+
+* Wed Jan 23 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.12
+       - theme : button icon - scrolltop, scrolleft icon changed.
+       - build: cleanaup Makefile
+       - pagelayout: fix jslint error
+       - virtualgrid: Fix jslint errors
+       - tabbar : jslint bug error fix
+       - build: add regexp option to jslint
+       - virtuallist: fix jslint errors
+       - handler: Apply the exceptional principle for scrollbar on Handler.
+       - build: remove unused copyright
+       - loader: extract log class for tizen web, and fix jslint errors
+       - loader: Viewport width is set to document width
+       - popupwindow: fix jslint error
+       - build: fix Makefile for tizen-white theme
+       - build: remove unused libraries
+       - datetimepicker: fix jslint error
+       - slider: fix jslint error
+       - demo: remove deprecated demos
+       - pagelayout : change to call relayout with this page
+       - Tokentextarea: Block size error fixed.
+       - handler: bug fix (handler activation)
+
+* Tue Jan 22 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.11
+       - demo: clear input text value with cancel button click
+       - demo: Adjust textarea height automatically
+       - naviframe : bug fix
+       - tabbar : bug fix
+       - Fastscroll: popup position has been changed
+       - Button: custom button icon path, margin have been changed
+       - toggleswitch : bug fix
+       - slider: increase the margin
+       - datetimepicker: close the popup after select the value
+       - unit-test : add page backbutton control test
+       - Demo: added guide text and change input type in list vi
+       - remove legacy codes : jquery-geo
+       - Datetimepicker: text-main max-width has been removed
+       - Radio: control group border has been removed
+       - Demo: remove 'tab' space
+       - UnitTC: swipe unit tc has been fixed
+       - UnitTC: jQuery path has been fixed
+       - Button: bug fix when button has not a text
+       - tizen-winset: timepicker: demo title is changed
+
+* Fri Jan 18 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.10
+       - tizen-winsets: codes cleanup
+       - datetimepicker: date calibration when year is changed
+       - Demo: textarea size has been changed
+       - Demo: Naviframe morebutton demo has been changed
+       - remove unused unit test cases : gallery3d
+       - tizen-winset: remove links
+
+* Thu Jan 17 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.9
+       - gallery: use timeout function instead of interval
+       - Tokentextarea: Display error fixed.
+       - scrollview: Fix not selector to respond with jQuery1.8.2
+       - tabbar: remove the width of last element
+       - Demo: apply css 'user-select:none'
+       - Button: guide text has been shorten
+       - build: Update jQuery to 1.8.2 (JQM1.2 compliant)
+       - virtuallist: Fix mistyping
+       - demo: Fix tizen function namespace in demo
+       - virtuallist: Rewrite listitem replacing algorithm
+       - fastscroll: modify from not selector to function
+       - extendablelist: Fix unit-test
+       - tabbar : prefix to tabbar scroll event
+       - Popupwindow: removed unvalid selector in jquery 1.8.2
+       - slider: adjust handle text as length of value
+       - Demo: 3 buttons in popup text has been changed
+       - src: codes cleanup
+       - demo : remove trailing empty strings
+       - demo : rename TizenWinset list items
+       - button : change from long text list to multiline list
+       - build: Remove JQM1.1.0 patches
+       - Popup: Apply tizen style popup and attribute support
+       - JQM: Fix buttonmarkup bug keeping ui-btn-down class
+       - UnitTest: folder and file renamed, QUnit path was modified
+       - tizen-winsets: button: fix textarea width
+       - Swipe: event name error has been fixed
+
+* Tue Jan 15 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.8
+       - Button: button padding has been updated
+       - virtuallist: fix unique listitem ID bug
+       - checkbox, radio : change display attr
+       - Button: bug fix ( when data style circle button on text )
+       - handler: bug fix (when scrolling with multi selection)
+       - JQM: adjust patch number
+       - gallery: show the widget after pageshow
+       - TokenTextArea : resource add ( press image )
+       - gallery: adds function that set the index to value API
+       - configure: set TIZEN default configures
+       - footer: h tag display attribute value has been changed
+       - buttons : demo bug fix
+       - searchbar : demo page bug fix
+       - tizen demo : bug fix
+       - build: remove JQM1.1.0
+       - Tokentextarea: Fix issues
+       - scrollview: block the multi touch
+       - list : dialogue list demo change
+       - pagelayout : update dynamic control
+       - Demo: Context popup close method has been changed
+
+* Fri Jan 11 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.7
+       - slider: set text container's width as text length
+       - Timepicker: li max-width has been changed
+       - remove experimental feature - mapview.
+       - scrollview: added conditions for finding slider
+       - UnitTC: Pass,error count save method has been changed
+       - confix.xml: default config added for tizen basic applications
+       - Swipe: p tag margin value is set '0'
+       - packaging: remove unused file
+       - tabbar : bug fix
+       - list demo : bug fix
+       - tizen-winsets: gallery: move to new section
+       - tizen-winsets: autodivider: removes link of list
+       - demos: entry of number-pattern name is changed from 'number' to 'number-pattern'
+       - pagelayout : padding calculate change, ime footer check changed
+       - tizen-winsets: searchbar: scroll to the top when type the character
+       - searchbar : bug fix
+       - demo: Fix virtuallist demo following new list style
+       - demo: Add word-wrap:break-word and remove parag. width
+       - Demo: button max-width has been set( 3 buttons in popup )
+       - back button control demo : bug fix
+       - toggleswitch : demo page modify
+       - slider: add margin-top and margin-bottom
+       - tabbar demo : bug fix
+       - Popup: IME hide when popup is closed
+       - token textarea : bug fix
+       - Timepicker: change get attribute method
+       - footer demo : bug fix
+       - unit-test: gallery: add new APIs
+       - gallery: adds support new APIs
+
+* Fri Jan 04 2013 Minkyu Kang <mk7.kang@samsung.com> 0.2.6
+       - JQM: patches cleanup
+       - Button: data-corners attribute has been added
+       - unit-test: slider: fix class name of background
+       - progressbar, slider: fix less variable typo
+       - Tabbar : VI update
+       - notification: add top position at fix class
+       - demo: entry demo page change
+       - css: .ui-disabled added
+       - tizen-winset: token textarea: remove back button at demo page
+       - theme: Remove unused less file
+       - pagelayout : content min height bug fix
+       - scrollview: skip the dragging when target is slider's handle
+       - scrollview: update and refactoring the scroll effect
+       - UnitTest:JQM Unit TC helper has been added,TCs have been modified
+       - Swipe: demo page html error has been fixed
+       - listview: Add add/delete animation (VI)
+       - Popup: demo page has been modified
+       - tizen demo : bug fix
+       - searchbar : demo page change(change front button and add behaviour)
+       - pagelayout : add min height to content
+       - gallery: rename 'Image Slider' to 'Gallery' in tizen-winsets demo and tests
+       - back button control demo : change url link to data-rel="back"
+       - loader: Skip loading theme CSS with a custom css code
+       - Button: support no-text in button
+       - collapsible: Fix syntax error
+       - slider: use data-highlight attribute
+       - collapsible: Rotate animation to collapsible heading icon
+       - toggleswitch : text switch bug fix
+       - remove candidates-calendarpicker
+       - Patch: Fix misc mistakes in JQM patches
+       - searchbar : animation change
+       - gallery: get the width correctly
+       - demo: data-framework-viewport-scale attribute is changed to data-framework-viewport-width
+       - collapsible: Add collapse/expand animation (VI)
+       - datetimepicker: VI update
+       - JQM: set transition to pop as default
+       - tabbar : bug fix in case none li element case
+       - scrollview: fix the drag bug
+       - Button: Button icon scrolltop, left has beed added
+       - Swipe: VI update and swipe speed has been changed
+       - jqm: fix errors in patch files
+       - unit-test: swipe: fixed the destroy test
+
+* Wed Dec 26 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.5
+       - Revert "[checkboxradio] exception handling for input"
+               This reverts commit 72478c32704fa96362db577e6cf9511777919ea8.
+               Tizen style supports no-label radio and checkbox when making lists.
+               So it ignores html input operation. Instead, it supports tizen style radio and checkbox theme.
+
+* Thu Dec 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.4
+- Fix:
+       - modify segment background
+       - rearrange check, radio input
+       - CtxPopup: Scale up/ down popup vi(poptop, popbottom)
+       - button: style has beed added(box,circle,nobg,round)
+       - favorite resource added
+       - demo/tizen-winsets: add footer and back button
+       - remove autodividers unit test
+       - add divider for tabbar
+       - checkboxradio: exception handling for input
+       - segment control backward compatiblity
+       - Fix collapsible unit-test
+       - remove toggleswitch
+       - add patch for remove segment text
+- Spec changes:
+       - replace controlbar to tabbar
+
+* Fri Dec 14 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.3
+- FIX:
+       - slider: add image
+       - button: data-icon support, styles fix
+       - progressbar: modify the background
+       - scrollview: auto scrolling bug fix
+       - pagelayout: IME concept is changed
+- Spec changes:
+       - dialogue: add edit mode
+       - nocontents: removed
+       - pagecontrol: removed
+       - dayselector: removed
+       - expandablelist: removed
+
+* Thu Dec 10 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.2
+- FIX:
+       - chang searchbar/slider images
+       - delete redundant button images
+- Spec changes:
+       - Change widget name: shortcutscroll -> fastscroll
+
+* Thu Dec 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.2.1
+- FIX:
+       - jqm1.2: Change collapsible style to meet expandable list
+       - remove jquery-geo-1.0.a4
+       - unit-test: rename from imageslider to gallery
+       - nocontent: add warning message
+       - Handler: Fix issues in jqm1.2
+       - Multimediaview: modify APIs & comments
+       - Mapview: Fix issues in jqm1.2
+       - JQM: clean up patches
+       - Swipelist: refactoring swipelist
+       - Popup,Ctxpopup: Apply tizen style popup in JQM1.2
+       - rearrange button's data-icon resources
+- Spec changes:
+       - Virtualgrid: remove option ('data-itemcount')
+       - gallery: rename the widget from imageslider to gallery
+       - add new style for searchbar
+       [tokentextarea] multi-button entry renamed as token text area. API & comments modified.
+
+* Thu Dec 06 2012 Minkyu Kang <mk7.kang@samsung.com> 0.2.0
+- FIX:
+       - fix jslint error
+       - remove unused files
+       - change naviframe style
+- Spec changes:
+       - applied jQuery Mobile 1.2.0
+       - remove optionheader
+
+* Fri Nov 30 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.64
+- FIX:
+       - fix unit tests
+       - remove unused theme files
+       - timepicker: text position fix
+       - scrollview: set dragstop when mouse is out of window
+       - listview: fix margin
+- Spec changes:
+       - support data-framework-viewport-width
+
+* Fri Nov 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.63
+- FIX:
+       - dayselector: fix size
+       - remove unised styles
+       - divider: set non-press effect to default option
+       - popupwindow: fix window closing failure
+       - handler: GUI implementation
+       - TC: fix unit TCs
+       - scrollview: fix padding size
+- Spec changes:
+       - Remove color widgets
+       - add $.tizen.pkgVersion for SDK
+- Etc.
+       - JSDuck documents
+
+* Fri Nov 16 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.62
+- FIX:
+       - Many winsets: Fix layout
+       - Footer: fix position to bottom
+- Spec changes:
+       - Remove color widgets
+
+* Fri Nov 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.61
+- FIX:
+       - Many widgets: New UX 0.6 theme implementation
+       - widgetex: init speed up
+       - scrollview: fix scrollbar and scale animation
+       - scrollview: fix scroll position when updatelayout is triggered
+       - header/footer: make textselection disable, except input type="text"
+
+* Wed Nov 07 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.60
+- FIX:
+       - Remove tizen-black theme package description
+
+* Tue Nov 06 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.59
+- FIX:
+       - Fix theme name to meet the change of system theme name: white->tizen
+       - Popupwindow: fix left position
+       - Remove black theme
+       - footer: remove label, legend drawing
+- Spec changes:
+       - UX guide v0.4 : button, layout
+
+* Wed Oct 24 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.57
+- FIX:
+       - expandablelist: icon color fix
+       - scrollview: Fix xy scroll
+       - footer: Remove dummy div
+       - Make string concatnation effective in inline-protos.sh
+- Spec changes:
+       - refresh header/footer when drag&drop event is fired in GUI builder
+       - searchbar: delete cancel button
+       - don't trigger updatelayout event when keyup event comes
+
+* Mon Oct 15 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.56
+- FIX:
+       - Toggleswitch: Change event name from 'changed' to 'change'
+       - Notification: Revert interval feature
+
+* Tue Oct 09 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.55
+- FIX:
+       - Fix SMACK manifest bug (S1-9098)
+
+* Fri Oct 05 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.54
+- FIX:
+       - handler: don't append a handler if handler is not enabled
+       - scrollview: use static value
+       - datetimepicker: fix date-format HH display error
+- ETC:
+       - provide jquery.min.js
+       - barlayout: codes clean
+       - remove unused file
+
+* Wed Sep 26 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.53
+- FIX:
+       - listview: change focused color
+       - multibuttonentry: code refactoring
+       - datetimepicker: modify date format when triggered date-changed event
+       - slider: fix the top of slider bar
+       - add event blocker when load a first page
+
+* Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.52
+- ETC.
+       - Move SMACK manifest files to the top SRCDIR
+
+* Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.51
+- FIX:
+       - Popup: Do not focus container
+       - Header: show backbutton when both tabbar and header are present together
+       - Multi button entry: text ellipsis, code refactoring
+
+* Fri Sep 21 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.50
+- ETC.
+       - Apply SMACK manifest
+
+* Thu Sep 20 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.49
+- FIX:
+       - JSLINT code clean-up
+       - scrollview: firefox support
+       - scrollview: fix finding slider handle
+       - list: tweak text ellipsis
+       - checkbox: fix selecting wrong label tag (N_SE-8370)
+       - imageslider: check parameter
+       - smallpopup: fix position
+       - searchbar: fix 'clear' button size
+- Spec changes:
+       - scrollview: support outer scroll
+       - JQM: block click event only with the element that does preventdefault on vclick(N_SE-6090)
+       - remove S/W IME control
+
 * Thu Sep 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.48
 - FIX:
        - Add missing icon: controlbar