Add common model default value for lcd backlight time.
[platform/core/appfw/vconf-internal-keys.git] / packaging / vconf-internal-keys.spec
index 6391d2f..fcb9f04 100755 (executable)
@@ -1,6 +1,6 @@
 Name:       vconf-internal-keys
 Summary:    Internal shared keys for vconf
-Version:    0.0.159
+Version:    0.0.160
 Release:    0
 Group:      Application Framework/Configuration
 License:    Apache-2.0
@@ -25,7 +25,6 @@ configuration internal shared keys
 %package devel
 Summary:    Vconf internal keys (devel)
 Group:      Application Framework/Configuration
-Requires:  pkgconfig(capi-base-common)
 
 %description devel
 Vconf internal key header files (devel)
@@ -94,35 +93,35 @@ mkdir -p scripts_wearable
 mkdir -p scripts_ivi
 
 %ifarch %arm aarch64
-make model=mobile
+make profile=mobile model=mobile
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_mobile/
 cp remove_keys.sh scripts_mobile/
 cp scripts/*.txt scripts_mobile/
 make clean
-make model=tv
+make profile=tv model=tv
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_tv/
 cp remove_keys.sh scripts_tv/
 cp scripts/*.txt scripts_tv/
 make clean
-make model=wearable
+make profile=wearable model=wearable
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_wearable/
 cp remove_keys.sh scripts_wearable/
 cp scripts/*.txt scripts_wearable/
 make clean
-make model=ivi
+make profile=ivi model=ivi
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_ivi/
 cp remove_keys.sh scripts_ivi/
 cp scripts/*.txt scripts_ivi/
 make clean
-make model=common
+make profile=common model=common
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_common/
@@ -130,35 +129,35 @@ cp remove_keys.sh scripts_common/
 cp scripts/*.txt scripts_common/
 
 %else
-make model=mobile/emulator
+make profile=mobile model=mobile/emulator
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_mobile/
 cp remove_keys.sh scripts_mobile/
 cp scripts/*.txt scripts_mobile/
 make clean
-make model=tv/emulator
+make profile=tv model=tv/emulator
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_tv/
 cp remove_keys.sh scripts_tv/
 cp scripts/*.txt scripts_tv/
 make clean
-make model=wearable/emulator
+make profile=wearable model=wearable/emulator
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_wearable/
 cp remove_keys.sh scripts_wearable/
 cp scripts/*.txt scripts_wearable/
 make clean
-make model=ivi/emulator
+make profile=ivi model=ivi/emulator
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_ivi/
 cp remove_keys.sh scripts_ivi/
 cp scripts/*.txt scripts_ivi/
 make clean
-make model=common/emulator
+make profile=common model=common/emulator
 awk '{ if ($5 == "\"memory\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_memory.txt
 awk '{ if ($5 == "\"system\"" ) print $LR }' ./scripts/all.sh | awk '{ print $6}' | sed -e 's/^"//' -e 's/"$//' | sort > ./scripts/vk_system.txt
 cp scripts/*.sh scripts_common/
@@ -259,31 +258,36 @@ rm -rf /opt/usr/vconf-internal-keys_scripts_ivi
 %posttrans config-profile_mobile
 TMP_AFTER=/opt/.runtime_vconf_internal_keys
 echo "running -------------------- DISABLE remove_keys.sh"
-#. /opt/usr/remove_keys.sh
+. /opt/usr/remove_keys.sh msg          # just print out messages
+#. /opt/usr/remove_keys.sh del         # remove the actual keys
 touch $TMP_AFTER
 
 %posttrans config-profile_common
 TMP_AFTER=/opt/.runtime_vconf_internal_keys
 echo "running -------------------- DISABLE remove_keys.sh"
-#. /opt/usr/remove_keys.sh
+. /opt/usr/remove_keys.sh msg          # just print out messages
+#. /opt/usr/remove_keys.sh del         # remove the actual keys
 touch $TMP_AFTER
 
 %posttrans config-profile_tv
 TMP_AFTER=/opt/.runtime_vconf_internal_keys
 echo "running -------------------- DISABLE remove_keys.sh"
-#. /opt/usr/remove_keys.sh
+. /opt/usr/remove_keys.sh msg          # just print out messages
+#. /opt/usr/remove_keys.sh del         # remove the actual keys
 touch $TMP_AFTER
 
 %posttrans config-profile_wearable
 TMP_AFTER=/opt/.runtime_vconf_internal_keys
 echo "running -------------------- DISABLE remove_keys.sh"
-#. /opt/usr/remove_keys.sh
+. /opt/usr/remove_keys.sh msg          # just print out messages
+#. /opt/usr/remove_keys.sh del         # remove the actual keys
 touch $TMP_AFTER
 
 %posttrans config-profile_ivi
 TMP_AFTER=/opt/.runtime_vconf_internal_keys
 echo "running -------------------- DISABLE remove_keys.sh"
-#. /opt/usr/remove_keys.sh
+. /opt/usr/remove_keys.sh msg          # just print out messages
+#. /opt/usr/remove_keys.sh del         # remove the actual keys
 touch $TMP_AFTER
 
 %files