update service untis to be installed in /usr/lib vs /lib
[profile/ivi/uxlaunch.git] / packaging / uxlaunch.spec
index f265f1a..57c12de 100644 (file)
@@ -7,6 +7,7 @@ License:    GPLv2
 URL:        http://www.tizen.org
 Source0:    %{name}-%{version}.tar.gz
 Source1:    uxlaunch.config
+Source2:    xterm.desktop
 Requires(preun): systemd
 Requires(post): systemd
 Requires(postun): systemd
@@ -40,13 +41,16 @@ make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
-mkdir -p %{buildroot}/%{_lib}/systemd/system/graphical.target.wants
-ln -s ../uxlaunch.service %{buildroot}/%{_lib}/systemd/system/graphical.target.wants/uxlaunch.service
+mkdir -p %{buildroot}/usr/lib/systemd/system/graphical.target.wants
+ln -s ../uxlaunch.service %{buildroot}/usr/lib/systemd/system/graphical.target.wants/uxlaunch.service
 %make_install
 
 install -D -p -m 0644 %{SOURCE1} \
     %{buildroot}%{_sysconfdir}/sysconfig/uxlaunch
 
+install -D -p -m 0644 %{SOURCE1} \
+    %{buildroot}%{_datadir}/xsessions/xterm.desktop
+
 %preun
 if [ $1 == 0 ]; then
     systemctl stop uxlaunch.service
@@ -67,12 +71,11 @@ systemctl daemon-reload
 %config(noreplace) %{_sysconfdir}/sysconfig/uxlaunch
 %doc %{_mandir}/man1/uxlaunch.1*
 %{_datadir}/uxlaunch/dmi-dpi
-/lib/systemd/system/uxlaunch.service
-/lib/systemd/system/graphical.target.wants/uxlaunch.service
+%{_datadir}/xsessions/xterm.desktop
+/usr/lib/systemd/system/uxlaunch.service
+/usr/lib/systemd/system/graphical.target.wants/uxlaunch.service
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/uxlaunch-ipc.h
 
-%changelog
-