Fix format-truncation warning for gcc9
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
index 8397126..c01a09d 100755 (executable)
@@ -3,27 +3,23 @@
 
 Name:          ug-setting-mobileap-efl
 Summary:       Tethering UI Gadget Library
-Version:       1.0.137
+Version:       1.0.162
 Release:       1
 Group:         App/Network
 License:       Flora-1.1
 Source0:       %{name}-%{version}.tar.gz
 
-%if "%{?profile}" == "wearable"
-ExcludeArch: %{arm} %ix86 x86_64
-%endif
-%if "%{?profile}" == "tv"
-ExcludeArch: %{arm} %ix86 x86_64
-%endif
-
 BuildRequires: pkgconfig(evas)
 BuildRequires: pkgconfig(elementary)
 BuildRequires: pkgconfig(ui-gadget-1)
-BuildRequires: pkgconfig(capi-network-wifi)
+BuildRequires: pkgconfig(capi-network-wifi-manager)
 BuildRequires: pkgconfig(capi-network-tethering)
 BuildRequires: pkgconfig(capi-network-connection)
 BuildRequires: pkgconfig(notification)
+BuildRequires: pkgconfig(aul)
+BuildRequires: pkgconfig(bundle)
 BuildRequires: pkgconfig(efl-extension)
+BuildRequires: pkgconfig(dpm)
 BuildRequires: cmake
 BuildRequires: edje-bin
 BuildRequires: gettext-tools
@@ -37,6 +33,9 @@ Tethering UI Gadget Library
 
 %build
 cmake -DCMAKE_INSTALL_PREFIX="%{_ugdir}"  \
+%if "%{?_with_emulator}" == "1"
+       -DTIZEN_FEATURE_EMULATOR=1 \
+%endif
        .
 
 make %{?_smp_mflags}
@@ -46,25 +45,10 @@ make %{?_smp_mflags}
 rm -rf %{buildroot}
 %make_install
 
-#License
-mkdir -p %{buildroot}%{_datadir}/license
-cp LICENSE %{buildroot}%{_datadir}/license/%{name}
-
 %post
-/usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -s ug-setting-mobileap-efl
-/usr/bin/vconftool set -t int file/private/libug-setting-mobileap-efl/wifi_popup_check_box_status 0 -u 5000 -i -s ug-setting-mobileap-efl
-/usr/bin/vconftool set -t int file/private/libug-setting-mobileap-efl/bt_popup_check_box_status 0 -u 5000 -i -s ug-setting-mobileap-efl
-/usr/bin/vconftool set -t int file/private/libug-setting-mobileap-efl/usb_popup_check_box_status 0 -u 5000 -i -s ug-setting-mobileap-efl
-/usr/bin/vconftool set -t int file/private/libug-setting-mobileap-efl/is_device_rename_local 0 -u 5000 -i -s ug-setting-mobileap-efl
-/usr/bin/vconftool set -t int memory/private/libug-setting-mobileap-efl/trying_usb_tethering 0 -u 5000 -i -s ug-setting-mobileap-efl
-
-mkdir -p /usr/apps/ug-setting-mobileap-efl/bin/ -m 777
-chown -R 5000:5000 /usr/apps/ug-setting-mobileap-efl/bin/
-chsmack -a "_" /usr/apps/ug-setting-mobileap-efl/bin/
 
 %files
 %manifest ug-setting-mobileap-efl.manifest
-/etc/smack/accesses.d/ug-setting-mobileap-efl.efl
 %defattr(-,root,root,-)
 /usr/ug/res/locale/*/LC_MESSAGES/ug-setting-mobileap-efl*
 /usr/ug/res/images/ug-setting-mobileap-efl/*.png
@@ -74,4 +58,4 @@ chsmack -a "_" /usr/apps/ug-setting-mobileap-efl/bin/
 /usr/share/packages/ug-setting-mobileap-efl.xml
 /usr/apps/ug-setting-mobileap-efl/shared/res/tables/ug-setting-mobileap-efl_ChangeableColorInfo.xml
 /usr/apps/ug-setting-mobileap-efl/shared/res/tables/ug-setting-mobileap-efl_fontInfoTable.xml
-%{_datadir}/license/%{name}
+%license LICENSE