Fix dlog format error
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
index e2b1756..b63a140 100755 (executable)
@@ -3,23 +3,16 @@
 
 Name:          ug-setting-mobileap-efl
 Summary:       Tethering UI Gadget Library
-Version:       1.0.147
+Version:       1.0.161
 Release:       1
 Group:         App/Network
 License:       Flora-1.1
 Source0:       %{name}-%{version}.tar.gz
 
-%if "%{?profile}" == "wearable"
-ExcludeArch: %{arm} %ix86 x86_64
-%endif
-%if "%{?profile}" == "tv"
-ExcludeArch: %{arm} %ix86 x86_64
-%endif
-
 BuildRequires: pkgconfig(evas)
 BuildRequires: pkgconfig(elementary)
 BuildRequires: pkgconfig(ui-gadget-1)
-BuildRequires: pkgconfig(capi-network-wifi)
+BuildRequires: pkgconfig(capi-network-wifi-manager)
 BuildRequires: pkgconfig(capi-network-tethering)
 BuildRequires: pkgconfig(capi-network-connection)
 BuildRequires: pkgconfig(notification)
@@ -40,6 +33,9 @@ Tethering UI Gadget Library
 
 %build
 cmake -DCMAKE_INSTALL_PREFIX="%{_ugdir}"  \
+%if "%{?_with_emulator}" == "1"
+       -DTIZEN_FEATURE_EMULATOR=1 \
+%endif
        .
 
 make %{?_smp_mflags}
@@ -49,10 +45,6 @@ make %{?_smp_mflags}
 rm -rf %{buildroot}
 %make_install
 
-#License
-mkdir -p %{buildroot}%{_datadir}/license
-cp LICENSE %{buildroot}%{_datadir}/license/%{name}
-
 %post
 
 %files
@@ -66,4 +58,4 @@ cp LICENSE %{buildroot}%{_datadir}/license/%{name}
 /usr/share/packages/ug-setting-mobileap-efl.xml
 /usr/apps/ug-setting-mobileap-efl/shared/res/tables/ug-setting-mobileap-efl_ChangeableColorInfo.xml
 /usr/apps/ug-setting-mobileap-efl/shared/res/tables/ug-setting-mobileap-efl_fontInfoTable.xml
-%{_datadir}/license/%{name}
+%license LICENSE