Add multi-user support.
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
index 8474428..8456979 100644 (file)
@@ -3,7 +3,7 @@
 
 Name:       ug-setting-mobileap-efl
 Summary:    Tethering UI Gadget Library
-Version:    0.1.158
+Version:    0.1.165
 Release:    1
 Group:      TO_BE/FILLED_IN
 License:    Flora License Version 1.0
@@ -12,6 +12,7 @@ Requires(post): /usr/bin/vconftool
 BuildRequires: cmake
 BuildRequires: edje-bin
 BuildRequires: gettext-tools
+BuildRequires: libtzplatform-config-devel
 BuildRequires: pkgconfig(elementary)
 BuildRequires: pkgconfig(evas)
 BuildRequires: pkgconfig(ui-gadget-1)
@@ -20,6 +21,8 @@ BuildRequires: pkgconfig(capi-network-tethering)
 BuildRequires: pkgconfig(capi-network-connection)
 BuildRequires: pkgconfig(capi-network-wifi)
 BuildRequires: pkgconfig(capi-telephony-sim)
+BuildRequires: pkgconfig(capi-network-bluetooth)
+BuildRequires: pkgconfig(notification)
 
 %description
 Tethering UI Gadget Library
@@ -36,16 +39,49 @@ rm -rf %{buildroot}
 %make_install
 
 %post
-/usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
+GID=$(getent group %{TZ_SYS_USER_GROUP} | cut -f 3 -d :)
+/usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -g $GID -f
+/usr/bin/vconftool set -t int memory/mobile_hotspot/wifi_state 0 -g 6519 -i -f
+mkdir -p /usr/ug/bin/
+ln -sf /usr/bin/ug-client /usr/ug/bin/setting-mobileap-efl
 
 %files
 %manifest ug-setting-mobileap-efl.manifest
 %defattr(-,root,root,-)
-%{_ugdir}/res/edje/ug-setting-mobile-ap-ug/*.edj
+%{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
 %{_ugdir}/res/locale/*/LC_MESSAGES/*
-%{_ugdir}/lib/libug-setting-mobile-ap-ug.so
+%{_ugdir}/res/images/ug-setting-mobileap-efl/*.png
+%{_ugdir}/lib/libug-setting-mobileap-efl.so
+/usr/share/packages/ug-setting-mobileap-efl.xml
 
 %changelog
+* Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.162-1
+- Maximum connection information is displayed
+- Implement connection timer
+- UX Change : Data usage and Connected device
+- Change ug name & Support appsvc
+- Translation data is updated
+
+* Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
+- Fix : The grouping of genlist item is wrong
+- Back button position and Naviframe title visibility are changed
+- Make grouping for genlist expanded item
+- Editfield change is applied
+- Ticker notification is implemented for passphrase entry
+- Implement title slide
+- Pop-up parent and entry's context menu allowance are changed
+
+* Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
+- Remove unrequired log
+
+* Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
+- Fix : When device is rotated, guide text is displayed short time
+- Fix : Security / Hide items are disabled sometimes
+- Translation data is updated
+- Pop-up scenario for USB tethering is implemented
+- IMF is hided by focus out
+- Wi-Fi tethering is enabled without checking enable state
+
 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
 - New winset is applied and some bugs are fixed