Fix for 64-bit build compatibility
[platform/core/telephony/telephony-daemon.git] / packaging / telephony-daemon.spec
index 6ac495b..4eaf2bf 100644 (file)
@@ -1,41 +1,47 @@
-Name:       telephony-daemon
-Summary:    Telephony daemon
-Version:    0.1.12
-Release:    1
-Group:      System/Telephony
-License:    Apache
-Source0:    %{name}-%{version}.tar.gz
-Source1:    telephony.service
+%define major 1
+%define minor 3
+%define patchlevel 24
+
+Name:           telephony-daemon
+Version:        %{major}.%{minor}.%{patchlevel}
+Release:        1
+License:        Apache
+Summary:        Telephony Daemon
+Group:          System/Telephony
+Source0:        %{name}-%{version}.tar.gz
 BuildRequires:  cmake
+BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(glib-2.0)
-BuildRequires:  pkgconfig(gobject-2.0)
 BuildRequires:  pkgconfig(tcore)
-BuildRequires:  pkgconfig(dlog)
+BuildRequires:  pkgconfig(vconf)
+Requires(post):           sys-assert
 
 %description
-Description: Telephony daemon
+Description: Telephony Daemon
 
 %prep
 %setup -q
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DVERSION=%{version}
-make %{?jobs:-j%jobs}
+cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+       -DLIB_INSTALL_DIR=%{_libdir} \
+       -DVERSION=%{version} \
+       -DTIZEN_DEBUG_ENABLE=1 \
+
+make %{?_smp_mflags}
 
 %install
+
 %make_install
 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
-install -m 0644 %{SOURCE1} %{buildroot}%{_libdir}/systemd/system/telephony.service
-ln -s ../telephony.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/telephony.service
-mkdir -p %{buildroot}/usr/share/license
+ln -s %{_libdir}/systemd/system/telephony-daemon.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/telephony-daemon.service
+
+%post -p /sbin/ldconfig
 
 %files
 %manifest telephony-daemon.manifest
 %defattr(-,root,root,-)
 %{_bindir}/telephony-daemon
-%{_initrddir}/telephony-daemon
-%{_sysconfdir}/rc.d/rc3.d/S30telephony-daemon
-%{_sysconfdir}/rc.d/rc5.d/S30telephony-daemon
-%{_libdir}/systemd/system/telephony.service
-%{_libdir}/systemd/system/multi-user.target.wants/telephony.service
-/usr/share/license/telephony-daemon
+%attr(644,root,root) %{_libdir}/systemd/system/telephony-daemon.service
+%attr(644,root,root) %{_libdir}/systemd/system/multi-user.target.wants/telephony-daemon.service
+%{_datadir}/license/telephony-daemon