Use %license macro in spec file
[platform/core/telephony/tel-plugin-vmodem.git] / packaging / tel-plugin-vmodem.spec
index 567e240..85120c2 100755 (executable)
@@ -1,6 +1,6 @@
 %define major 0
 %define minor 1
-%define patchlevel 23
+%define patchlevel 27
 
 Name:           tel-plugin-vmodem
 Version:        %{major}.%{minor}.%{patchlevel}
@@ -10,8 +10,11 @@ Summary:        Telephony AT Virtual Modem library
 Group:          System/Libraries
 Source0:        tel-plugin-vmodem-%{version}.tar.gz
 
-%if %{_with_emulator}
-%else
+%if "%{profile}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%if "%{_with_emulator}" != "1"
 ExcludeArch: %{arm} aarch64
 %endif
 
@@ -42,11 +45,10 @@ make %{?_smp_mflags}
 
 %install
 %make_install
-mkdir -p %{buildroot}/usr/share/license
 
 %files
 %manifest tel-plugin-vmodem.manifest
-%defattr(644,system,system,-)
+%defattr(644,root,root,-)
 #%doc COPYING
 %{_libdir}/telephony/plugins/vmodem-plugin*
-/usr/share/license/tel-plugin-vmodem
+%license LICENSE