Use %license macro in spec file
[platform/core/telephony/tel-plugin-vmodem.git] / packaging / tel-plugin-vmodem.spec
index 42f5732..85120c2 100755 (executable)
@@ -1,14 +1,23 @@
 %define major 0
 %define minor 1
-%define patchlevel 18
+%define patchlevel 27
 
 Name:           tel-plugin-vmodem
 Version:        %{major}.%{minor}.%{patchlevel}
 Release:        1
-License:        Apache
+License:        Apache-2.0
 Summary:        Telephony AT Virtual Modem library
 Group:          System/Libraries
 Source0:        tel-plugin-vmodem-%{version}.tar.gz
+
+%if "%{profile}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
+%if "%{_with_emulator}" != "1"
+ExcludeArch: %{arm} aarch64
+%endif
+
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(dlog)
@@ -36,11 +45,10 @@ make %{?_smp_mflags}
 
 %install
 %make_install
-mkdir -p %{buildroot}/usr/share/license
 
 %files
 %manifest tel-plugin-vmodem.manifest
-%defattr(-,root,root,-)
+%defattr(644,root,root,-)
 #%doc COPYING
 %{_libdir}/telephony/plugins/vmodem-plugin*
-/usr/share/license/tel-plugin-vmodem
+%license LICENSE