Generate Licence file
[platform/core/telephony/tel-plugin-vmodem.git] / packaging / tel-plugin-vmodem.spec
index 89e8d91..5b3e8da 100644 (file)
@@ -1,11 +1,11 @@
-#sbs-git:slp/pkgs/t/tel-plugin-vmodem
 Name:       tel-plugin-vmodem
 Summary:    Telephony AT Virtual Modem library
-Version: 0.1.8
+Version:    0.1.8
 Release:    1
 Group:      System/Libraries
-License:    Apache
+License:    Apache-2.0
 Source0:    tel-plugin-vmodem-%{version}.tar.gz
+Source1001:    tel-plugin-vmodem.manifest
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  cmake
@@ -18,9 +18,10 @@ Telephony AT Modem library
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%cmake .
 make %{?jobs:-j%jobs}
 
 %post
@@ -29,13 +30,12 @@ make %{?jobs:-j%jobs}
 %postun -p /sbin/ldconfig
 
 %install
-rm -rf %{buildroot}
 %make_install
 mkdir -p %{buildroot}/usr/share/license
+cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
-%manifest tel-plugin-vmodem.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
-#%doc COPYING
 %{_libdir}/telephony/plugins/vmodem-plugin*
-/usr/share/license/tel-plugin-vmodem
+/usr/share/license/%{name}