Generate Licence file
[platform/core/telephony/tel-plugin-vmodem.git] / packaging / tel-plugin-vmodem.spec
index 00efa44..5b3e8da 100644 (file)
@@ -3,8 +3,9 @@ Summary:    Telephony AT Virtual Modem library
 Version:    0.1.8
 Release:    1
 Group:      System/Libraries
-License:    Apache
+License:    Apache-2.0
 Source0:    tel-plugin-vmodem-%{version}.tar.gz
+Source1001:    tel-plugin-vmodem.manifest
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  cmake
@@ -17,6 +18,7 @@ Telephony AT Modem library
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 %cmake .
@@ -30,9 +32,10 @@ make %{?jobs:-j%jobs}
 %install
 %make_install
 mkdir -p %{buildroot}/usr/share/license
+cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
-%manifest tel-plugin-vmodem.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/telephony/plugins/vmodem-plugin*
-/usr/share/license/tel-plugin-vmodem
+/usr/share/license/%{name}