Initial refactoring merge
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
index d023dc2..fe33031 100644 (file)
@@ -1,11 +1,15 @@
-#sbs-git:slp/pkgs/t/tel-plugin-indicator
+%define major 3
+%define minor 0
+%define patchlevel 1
+
 Name:       tel-plugin-indicator
 Summary:    Telephony Indicator plugin
-Version: 0.1.7
-Release:    2
+Version:        %{major}.%{minor}.%{patchlevel}
+Release:    1
 Group:      System/Libraries
-License:    Apache
+License:    Apache-2.0
 Source0:    tel-plugin-indicator-%{version}.tar.gz
+Source1001:    tel-plugin-indicator.manifest
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  cmake
@@ -18,9 +22,10 @@ Telephony Indicator plugin
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%cmake .
 make %{?jobs:-j%jobs}
 
 %post 
@@ -29,13 +34,12 @@ make %{?jobs:-j%jobs}
 %postun -p /sbin/ldconfig
 
 %install
-rm -rf %{buildroot}
 %make_install
 mkdir -p %{buildroot}/usr/share/license
+cp LICENSE %{buildroot}/usr/share/license/%{name}
 
 %files
-%manifest tel-plugin-indicator.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
-#%doc COPYING
 %{_libdir}/telephony/plugins/indicator-plugin*
-/usr/share/license/tel-plugin-indicator
+/usr/share/license/%{name}